New laptop won't recognize WD Easystore drive - still works on old laptop

Some time ago I got a 8 TB WD Easystore external hard drive which I’ve backed up a lot of data to. Recently my laptop began suffering from hardware problems, and as it was over 5 years old I just went ahead and bought a new one. However, the new laptop will not acknowledge the existence of the Easystore at all. When plugged in, the light comes on and it makes noise, but it not only is not accessible from Windows Explorer, it doesn’t even show up anywhere in my Device Manager - including under “Other Devices” or the like. Another external hard drive has worked when plugged into either USB port, making me think the problem is not with them. Meanwhile, as the title says, I can still access the Easystore just fine from my old laptop.

The only thing that occurs to me is that some time ago, I wound up repartitioning the Easystore (long store), which may have wiped out the WD software it came with? I always manually copy files rather than use software to back them up, so I didn’t really pay attention to the details, but I wonder now if this could be part of the problem.

Please help however you can. I can technically copy files off of the drive by using my old laptop and the other hard drive as a go-between, but it’s extremely inconvenient and I don’t know how long the old laptop will work anyway. I have tried searching for help but found nothing useful so far.

This means you have read the FAQ?
There you have found at third position ID12455?
You have performed all of the checks listed there to no avail?
Then: why dont you report any of the results?

In case you have not found ID12455: what exactly have you searched for?

Most of what’s found in that particular FAQ entry does not apply. As I already said, the drive does not appear in any way on my new laptop. It does not appear in Disk Management, Device Management, or on the system tray. Meanwhile, other drives and my mouse work just fine, suggesting that there is nothing wrong with the laptop’s USB ports, and the drive itself works just fine on my original laptop, suggesting that it is not damaged.

I have not attempted to adjust the USB Root Hub power controls, so I will try that now, but otherwise I’m not seeing anything on that entry that appears relevant to the problem I am experiencing.

Edit: I can now confirm that adjusting the USB root hub power controls as detailed on the FAQ did nothing to make the drive appear anywhere.

UPDATE:

I tried switching out the USB cable that came with the Easystore drive for the cable that came with the drive I have been able to use - and the drive appeared! I thought this seemed like an extremely unlikely solution as this cable is in fact considerably older, and I’m at something of a loss to explain why it worked, but it did.

had the same issue and changing the usb cable helped me))