New G-RAID 20TB drives TB3 daisy chain simply not working

I work in Film/TV a d I have two brand new G-Raid drives here. They will not daisy chain at all, I’ll go over what I have tested below.

This is not the first time I have had this happen with new G-Raid drives, and I have checked with my peers and colleagues within the industry and in the 30 minutes the post has been up I have had two other members of m profession confirm they have had the exact same issue. They are both, thus far, from the UK - in case this is related to a faulty batch.

Testing process:

*Drives individually connected one at a time via TB3 - confirmed they work as expected. This is true of all Thunderbolt ports, they all allow the drive to connect without issue directly.

*Used box provided cables
*Used known good premium (Caldigit) TB3 cables
*Check System Profiler to confirm no other drives exist on the daisy chain.
*Swapped the drives around
*tried all combinations of ports for the chain
*connected directly from the MBP and also from a Caldigit TS3+
*Tried connecting the second drive from the daisy chain to it’s USBC port
*Tried connecting a different TB3 accessory to the GRAID TB3 port
*Confirmed daisy chaining of other devices works as expected.
*Turned on drives with full chain connected
*Connected chain after drives have been turned on
*Restarted MBP with drives connected to chain and no other peripherals connected
Edit:
Now also:
*Connected to a separate system (PC) still not working
*Forced TB2 connection with two Apple TB3>2 adapters at either end of a TB2 cable.

Along with a few other things I’m sure. Both drives are simply refusing to allow any kind of device to be daisy chained to them.