"Network shares" is empty - doesn't do anything

I’ve been searching and trying everything I can find online about getting this brand new WDTV Live to watch videos over the wireless network and nothing is helping. When I try and open “Network shares” in the menu nothing happens, doesn’t ask for a password, doesn’t load, doesn’t even give an error, no usefull information whatsoever. It just sits there as if I didn’t try and go into “Network shares”. I’ve also tried leaving it there for a long time, incase it was accessing something without telling me but nothing happened.

This is really dissapointing as I payed extra for the WD Live to use the networking and now feel like I made a bad choice.

I’ve tried uninstalling some Windows live ID, followed a few video tutorials, searched, etc and nothing’s changed.

Some info on the setup…

Watching youtube works fine.

I can access the videos on the USD HDD connected to the WD Live via a PC, and watch them without a problem,

The PCs (1 Windows 7 and 1 XP) can see and access files on eachother and the WD Live without problems. So it definately seems as if the WDTV in “connected”, it’s in the same workgroup etc.

I can ping the WD Live (which doesn’t say much since the PC can access the USB-HDD videos attached to it)

I don’t see much point in posting what my current settings are as I’ve tried so many combinations, it’s been about 6 hours now since I plugged that little devil box in, but here goes anyway I guess…

Home Network

-Network discovery -on

-File and printer sharing -on

-Turn on sharing so anyone -on

-media steaming -off (I’ve tried on, it even had the WD Live in the list of devices at one point without any good)

-Use 128bit -on (tried off)

-Turn off password protected sharing (tried on)

-Use the user accounts and passwords to connect… (tried the "Allow windows to manage…)

The shared folder has “everyone” allowed to access it and other PCs do so just fine.

Here’s some pics which might have useful information…

http://www.yayimg.com/images/644l8zzjjdtdegdhxe1.jpg

http://www.yayimg.com/images/4c8qsqi4s4fy1y4y3mzu.jpg

http://www.yayimg.com/images/v984frejv7e276rhn5.jpg

Windows (useless) firewall is disabled on all PCs and never used. I’ve tried disabling the used firewall and all security yet the WD TV Live still won’t do anything when I try and enter or access “Network shares” in the menu.

Someone please help, I’m really wishing I didn’t get this thing and to make it worse it’s a gift for someone.

edit------

Some more things I tried and may as well mention, on the Windows 7 PC I’ve edited the registry from information I found and that didn’t help, though I wasn’t to hopeful since it can’t see the XP shares/PC either.

This is how to find possible problems with the Master Browser on your network, which will affect when and what servers appear on your WDTV Network Shares.

On one of your PCs, open up a “Command” window.

(In Win Vista and Win7, click the Orb, and in the search box, type CMD. An icon will appear above the box that says cmd.exe. Click it, and a Command window will open.)

(In WinXP, Click START, then RUN…, and in the box, type CMD. A Command Window will open.)

In the command window, enter the command “net view,” like this:


C:\Users\Tony>net view
Server Name Remark


\BIGNAS1 Big Freakin’ NAS Server 1
\MARS
\NEPTUNE
\WDTVLIVE WDTV LIVE
The command completed successfully.

In my example, there are four active devices that Windows has discovered.

Now, for EACH of those, issue the command “nbtstat -a (name)” for example:

C:\Users\Tony>nbtstat -a bignas1

Local Area Connection:
Node IpAddress: [10.0.0.157] Scope Id: []

NetBIOS Remote Machine Name Table

Name Type Status

BIGNAS1 <00> UNIQUE Registered
BIGNAS1 <03> UNIQUE Registered
BIGNAS1 <20> UNIQUE Registered
…__MSBROWSE__.<01> GROUP Registered
WORKGROUP <1D> UNIQUE Registered
WORKGROUP <1E> GROUP Registered
WORKGROUP <00> GROUP Registered

So, we got lucky here, the FIRST system, BIGNAS1, indicates that it is the master browser, since it lists the name …__MSBROWSE__.

You need to find out WHICH system is your master browser. If none of these steps work as described, then the issue is likely on your PC itself, and that will require substantial additional troubleshooting.

Thanks for the reply Tony, any help is really appreciated.

The Windows 7 system is, and has consitently been, the master browser. Infact I’ve never checked and seen that it isn’t, which isn’t surprising as it’s only off when restarting for whatever reason.

I’m not exactly new to networking, though no expert, been playing around with it since Windows 9x days with horrid laplink cables and RAS connections. Only times I’ve had a problem with networking was with a dodgy ethernet cable and a faulty USB port, and of course this little devil box.

I really don’t know what else to try at this point, all the computers can access eachother aswell as the files on the WD Live’s USB HDD. Yet the WD TV Live doesn’t do anything when selecting network shares dispite there being 2 XP and a Win7 PC happily sharing things between eachother. The WD is the only one not playing along.

Also looking at the number of similar problems with this from search results it’s clear this WD TV Live is far from polished when it comes to it’s networking. I’m at the point where I regret not having done research for problems before buying it.

I guess now is about as good a time as any to add that the apparently certified USB dongle I purchased with it doesn’t infact work with it, though fortunarely one of the other’s I already had did. So far the only networking that does work is internet (youtube etc) which I honestly couldn’t care less about so I’m left shaking my head.

If your familiar with networking, then a Wireshark capture would be your next best bet. So far, EVERY issue I’ve troubleshot for people here has been an issue with something OTHER than the wdtv. Send me a PM if you need help diagnosing What’s usually causing this issue is the master browser not providing the list of servers when the WDTV requests it.

Hi Tony,

I have been following this thread with interest as I have the same problem. Following your instructions I find that my WDTV Live has the line concerning the master browser. What does this mean and where do I go from here?

Lan258:  Turn off your WDTV for a little while.   Wait to see who becomes the Master Browser after the WDTV is removed.   It might take a while…

Then, turn the WDTV back on.   Does it take over Master Browser again?

Tony, what would you suggest I do with Wireshark? Also thanks but I don’t see the point in taking the problem to PMs as if this is ever sorted out it could be handy to others if they could read how it was solved in the thread.

Ian258 I don’t mean to be rude, but things would be alot easier keeping each problem in it’s own thread, things would become harder to keep track if many people started posting various problems and suggestions in the same thread. You’d also get more attention to your problem with it’s own thread.

Browser wrote:

Tony, what would you suggest I do with Wireshark? Also thanks but I don’t see the point in taking the problem to PMs as if this is ever sorted out it could be handy to others if they could read how it was solved in the thread.

 

Browser:   No worries, then…  There are QUITE a few other threads here you can read to get the same info I’d give you anyway.

Starting with this one:   http://community.wdc.com/t5/Networking/How-to-run-WIRESHARK/m-p/33862/highlight/true#M3080

And the reason for PMs is because I was going to give you some information that I don’t want made public, but never mind…  

make sure you have turned Auto Login OFF

Auto Login

Use this menu to select a login procedure. When set to On, the media player logs into the network share anonymously. When set to Off, the media player prompts you to enter the account name and password to access the network share.

WD TV Live/WD TV Live Plus HD Media Player User Manual

SETTINGS AND ADVANCED FEATURES – page 164/165

Br,

shpokas

Thanks shpokas, I’m not sure if I tried it with Auto Login off yet but I’ll give it a try to make sure. TonyPh12345, basically you’re saying you don’t want something that might potentially help get this thing to work, to be public knowledge. Wow, I don’t know where to being with that, do you think everyone is going to “haxor” the planet because you made a post about wireshark. Please nevermind, this is rhetorical.

This is rhetorical, too:   I was going to give you the UserID and password to my FTP server so you could send me the wireshark capture and I’d do the hard work for you.    That’s something I don’t want to post in a public location…

shpokas wrote:

 

Auto Login

Use this menu to select a login procedure. When set to On, the media player logs into the network share anonymously. When set to Off, the media player prompts you to enter the account name and password to access the network share.

 

To be more precise, Auto-Login uses the LAST SUCCESSFUL CREDENTIALS you provided.     It does NOT log in only anonymously, unless that’s what you provide the first time.