Network Share Not Accessed on Mac

I’ve done a lot of searches and read a lot, but still can’t figure this out. I’ve got a WDTV Live wired to my router and I’m trying to play files from my Mac. I’ve turned on File Shares, added the folders I want, etc., on my Mac. When i go into videos, my WDTV lists my Mac, but when I click on it I get “Network Share Cannot be Accessed”. I’ve cleared the login and tried again (repeatedly). On my Mac, the WDTV is also listed in the Finder under Shares, and I can see the files on the thumb drive I have in the WDTV.

I’ve read about problems with Samba, permissions, login names, etc., but I can’t figure anything out. This is driving me crazy. I know this worked back a few years, but I’ve been copying stuff to a thumb drive for a while since I didn’t have the WDTV hooked up to my network, but it is now.

Can anyone help?! Before I completely lose my mind! I’m on OS X Yosemite, and my WDTV just had me update the firmware.


I haven’t try that. Let’s see if any of the user can share some information about it.

I have exactly the same problem. I have been using wdtv live smp attached to my router and running setup on my own El Capitan. It used to work flawlessly both ways but for the last few weeks I cannot access my wdtv USB drive from my Mac. Although I never used to need it, I switched on Samba. If works fine but I still cannot see my wdtv content from my Mac. I have tried all that OP did, no luck. I would love to know the cause. I still use my amp all the time but now have to store files on my Mac, not my favourite setup.