Network Connection Failure (905)

I was able to setup my new WD My Cloud without a problem. I can connect to it from inside my network but when I try to connect outside my network with my Android device I keep receiving the error Network Connection Failure (905).  Connecting remotely was the main reason I wanted this product, if I can’t connect this is worthless to me!

1 Like

Welcome to the Community.

Can your Android device access your files while on the same local network as your WD My Cloud? While outside of your network, do you get this error message while using your data plan, or when using WiFi?

I can access the files while in my network from the Android device without a problem. From outside I’ve tried it using WiFi and then just my data plan. Wondering if this could be because I have a password on my router for access? I can’t be the only one yo have it setup that way though.

1 Like

Maybe you should try contacting WD’s Technical Support about this. You can do so either by phone or email.

To Contact WD for Technical Support

Support by Country

YEAH Wd support gave me the standard script answer…reset to factory defaults.  I figured this out on my own…remote access was not turned on for my router.  Oncer I configured all is well.

Did you change your router first, or did you do the factory defaults then change your router.

Which setting exactly did you change on the router?

I was having the exactky the same error in Android when trying to access My Cloud from an external network and I was able to fix it changing a router configuration: enabling Port Forwarding. This link has the complete steps in order to achieve this:,487

Hope this helps.

Hi there,

Let me tell you, this… when I first got My Cloud Mirror (8TB), all was working great; I was able to access all of my files, from my LAN and from the WAN (Outside my home); but, all of the sudden (about a year ago, after 1st setup), my Android cell phone started to give me the error: “My Cloud - Network connection failure (905).” I close the app, rebooted my cell, and no go.

The only way to fix it was to uninstall the WD app and re-install it. Then, the problem reoccurred (same thing as before, I noticed the app has gotten updated). So, I tried the same process as before, and “no go” this time. So, this time for me in order to “fix it” temporarily, was to go to the My Cloud Dashboard and from the Cloud Configure Access; I had to delete the device (Android cell phone) from my account name. But, again, this works just for some days, because now, the problem is intermittent, and MyCloud App works fine, only when I’m at home (LAN).

It would be weird I will be able to access my files, music, etc, from the WAN. So, today, I came and tried your suggestions, about setting up the Cloud Access Connection Options, and setup accordingly… however, now, I’m getting a bit different error message: “My Cloud - Network connection failure (906).” (now the number changed from 905 to 906). This is getting too frustrating since this is really a no brainier setting up this cloud drive. But, it looks, WD has been making changes, that may be affecting the Android platforms, and let me tell you, this is not just happening on my phone, but, on all the accounts I’ve created for my family. Definitively there has been some changes, that WD needs to address and verify… since, the access to this cloud drive is intermittent etc… and all that started to happen since last year when I noticed they pushed a newer app update and firmware updates to the actual cloud drive.

I hope there could be some other Troubleshooting process I may still be able to do/check, but, this is not the way this technology suppose to behave on regular End Users.

Please, let me now should there be another alternatives to get fixed this annoying bug.

Your help is much appreciated.

Thank you


Support has been trying to contact you by email to address your concerns. Did you receive the email?

Yes I received the email,

How about today @ 7PM Pacific Time or troubleshooting the issues?

Thank you

If haven’t, you will need to email them back to set up a time for a call. That’s not something I can do.

I have the same problem “Network Connection Failure (905)” today, 03/14/2017. It only happened when I use T-Mobile data access network while it works fine with my local WiFi. The way I solved the problem is quite simple as following:
Do the Power Cycle Networking Equipment, A Power Cycle may be required to achieve full networking functionality for consumer networking equipment.

Power OFF the Router, Gateway and or Switch
Power ON the Router, Gateway and or Switch
Power OFF the My Cloud
Power ON the My Cloud

It will need some time period to wait for My Cloud to turn on. Once the My Cloud is on, all its functioning are back to work properly and I can access all my files from all my devices through local network, WiFi or Phone Internet data accessing.

I have had it with this drive. I am going to buy a simple SSD backup drive that connects by usb cable and just drag and drop onto it. Then I will know where my stuff is, and if it is there, and that there are no duplicates.
This WD cloud has been nothing but a headache and problems and wondering if my stuff is backed up, and why it’s in Public instead of the folder I set it go to to. And what’s the use of network access if I get an error half the time? The support is WAY to complicated, and I’ve been using computers for thirty years! Here’s an example:
I try to find an item from my android phone and get Error 971, not untypical. Here is the help:

  • My Cloud device is powered off
  • Device was reset to factory defaults
  • Unable to connect to my cloud servers
  • Misconfigured router
  • My Cloud device did not obtain an IP address from the router
  • Filtered or blocked ports by the ISP
  • Restriction by fireWall and/or end point protection software on the local network
    AWSOME! I can tackle number one: power it up. What the heck are those other things, and how do I go about fixing it??? What a joke. This thing is not worth the hassles I have had. The guy who recommended it to me has died, so I have no hope of making it work, or maybe even getting my stuff of of it! ■■■■ you, WD!
    I can’t get to all of my files from my pc, as only some of them show up (???) Where is the Public folder? Why are many years of photos not there? This thing is hopeless, and I can’t wait to see it in a box on the back step.