Issue with new WD App for Android

Hi There!

Yesterday I got the update for the My Cloud App in Android, I have my Galaxy S5 running with Lollypop. 

After updating, I had to fix several things in order to get connected, after adding the drive localy, I found I couldn’t get connected when leaving home through the phone. Wether I’m on wifi or cell network.

I already went through the troubleshooting and what really bothers me, is that in my iPod touch I just installed the app and everything works fine, so I have remote access working, just my Android phone couldn’t connect with my drive.

Finally I reset all the applicaction data on my phone, used the “My Cloud” password to set the access, I can see the users main folders, but when I try to open any of them (to which I granted my self all access) then gives a Network Connection Error.

Are others having the same issue?

I get network connection failure (906) on my Galaxy S5 running Lollipop. I cannot even see the folders. This started with the firmware update to my MyCloud as well.

Good evening,

Thank you for reporting the “Network Connection Failure (906)” you’re experiencing with the upgrade to My Cloud OS 3.

This information has been forward to our engineering teams.


Samuel Brown

its the same from the ios app and android app all showing network connection errors.906

Same here, Network connection failure (906) when ouside home network on Galaxy Note 3 running Lollipop (Android ver 5.0). Updated Android app and WD My Cloud firmware

We have passed along this information to WD Support.



Playing with the new Android MyCloud app today, accessing my two clouds.

The cloud with cloud access enabled worked fine

The cloud with cloud access disabled gave ‘Error 906’.  I think…

Maybe check that cloud access is enabled?

Yes, mine is enabled, are you using lollipop in your android device?

No. 4.2.2

That’s why you have access :smiley:


  I am also having a problem and experiencing the network connection error thing. I’m using a Samsung S4 with the latest software update (whatever that is)  Help!!


Remote access is working fine for me with Lollipop on Galaxy S5 (latest App and MyCloud Firmware).

I have upgrade from V3 on MyCloud  to the latest firmware and remote access actually feels snappier.

My Cloud 4.4.1 for Android is now available for download.

_What’s New:

  • Fix for Network Connection Failure (906)_

They seem to have broken it again in MyCloud 4.4.2 as this is what I get when I try to access it from my S4 mini running Android 4.4.2

Try uninstalling the app then reinstall it. That sometimes fixes weird issues.

I had the same 906 network error. I uninstalled and re-installed the mycloud android app and it seems to have worked. I’ll let u all know how it goes.

I kept having the same prob, dunno if my solution will work for everyone but I went into my app settings and opened “my cloud” in settings, then clicked the option clear cache and data. closed settings and then opened my cloud app and it was like I have just installed the app fresh so entered my login details and it works. Im guessing the 906 error is an error between saved login details and access to files/folders for certain versions of android. hope this helps.

Hi, I am facing the ‘Network connection failure (906)’ error recently. Previously the app on my android Samsung phone was working fine and now I get this error. I notice I can access when I am connected directly in the same LAN as my NAS. But once I use my mobile data plan to access, it give me this error.

I suspect is the android app (My Cloud) bug for this version 4.0. Please check.

I suspect your router has rebooted and been assigned a different IP address.

Turn off Cloud Access, and then turn it back on again to re-establish the connection.

The bug is with the MyCloud not being able to cope with router IP changes.

thanks. it works.