Need Help - WD Live Streaming Player

I am having weird issues with 2 of my WD TV.

Products I have -

  1. WD TV Live Hub Media Center : WDBACA0010BBK-00, Firmware shows 3.12.13
  2. WD Live Streming Media Player : WDBGXT0000NBK-01, Firmware shows 1.04.12

Problem started 3 days ago when i tried to connect an Ethernet cable to Live Hub, it rebooted and until i take the cable out it keeps on rebooting by itself. If i unplug the cable, it will keep on rebooting by itself.

After a while i connected Live Sreaming media player with same cable and did same. Even if i try using wireless on Live streming Media player, it reboots.

To resolve this, I have done following but no luck :

Replaced NW cable
Fectory Reseted Router, and both WD Players
Replaced to other Router, worked fine for first time and same issue arise
UPNP is off on router.
I tried downloading files to update firmware, it doesnt detect the new firmware so i cant update.

Any suggestions would be really helpful

I too have a WD Live TV, WDBGXT0000NBK-01, running firmware 1.16.13.

I normally run with it connected to my local network through a cable. It was OK on the morning of 16th May, but as I was watching in the evening it started constantly rebooting, as you say. Eventually I realised that if I unplugged the Ethernet cable it ran normally.

I ran a network trace (I have the facilities), but I can’t see anything that looks abnormal. Some of the traffic is encrypted with TLS, so I can’t see it fully anyway.

I upgraded to 2.02.32, and that fixed the problem. However, the box was very sluggish responding to the remote control (probably because the firmware is so bloated compared to the power of the hardware). In particular, fast forward/rewind was practically unusable because the box didn’t respond to the stop button on the remote in an acceptable time. I’m playing mostly 720p 50fps files, though the response seemed OK maybe on lower-definition files. I found it responded instantly to a USB keyboard when configuring the device (not that that’s much help).

I’ve downgraded back to 1.16.13 and I’ll use it for now watching files on USB sticks (sneakernet). At this point I’ve given up on the WD TV Live, and I’ll buy a replacement product.

As for upgrading, I too found new firmware wasn’t recognised until I realised I’d set System / Auto Detect New Firmware to Off. I had assumed this setting was just for detecting new firmware online, but in fact it’s for local firmware. After I’d set it On, I could upgrade as per the instructions from WD.

One more thing – if it’s possible to edit the title of your posting, I suggest you change it to something more descriptive, to help other people find your post in future.