Need help - How to share additional windows media folders

Hi,

I am trying to view media stored on my windows 8.1 PC on my WD TV Live Media Player (WDBHG70000NBK). Firmware 2.02.32.
I am able to only see the c:\users\public folder and subfolders.  As I store my media on two external drives that are connected to the Intel Nuc PC (USB 3.0), so I want
to be able to "add these drives\folders to the WD media player, which seems possible via the user manual.  In my case I want to add media files from my D: drive (an external HD).

I have tried to look through the forum for something similar but I did not see it, but I may not be looking for the correct title. 

I enabled sharing of the drives per the instructions in the WD support document #3787http://wdc.custhelp.com/app/answers/detail/a_id/3787/session/L3RpbWUvMTQyMjgxODE2Ny9zaWQvMXVTdVlXZG0%3D
I go to files on the WD TV live screen and go to the  “Files” tab (in pink).
What appears is the “Users” folder on the C drive on my PC.  
I then click on the Red button. “Select Content Source”  appears.  I choose “Network Share”.
I then get an option to select “Windows Shares” or “Mac Shares”.  I select “Windows Shares”.
My PC name comes up, in this case “HOME-PC”.  I select it and get the following message
“To add a folder from the network share to the media library, use the option menu or go to the media library manager from setup.”  Let’s try those two options:

–Option menu (i beleive this is the options button on the remote control)
I select the “option” button on the remote control.
I then get a screen that shows the “Users” folder with options
None of these options appear to do what I need, which is to add a drive/folder from my PC that is not under c:\users

–Media library manager from Setup
I then go to the setup tab (Purple).  I select “System” -> “Media Library” -> “Media Library Manager for Network Share”.
I tried adding a new network share to the media library but no luck.

I have tried to be as explict and step by step as possible.  I can’t imagine I am the first to see this issue.

Any ideas?

thanks!

andrew

Hello and welcome to the WD Community.

On the support link that you provided, did you tried both options listed for Windows 8

Hi,

Thanks for your reply!  I went back and double checked that I followed the instructions for both items.  It looks like I am following them as documented.

Couple of questions.

  1. As I am sharing a folder from a PC, will the files appear in the “files” tab or the “Video” tab on WD TV?  I assume the “Files” tab, but want to confirm.

  2. My network setting on my PC states I am in a Private Network, so was wondering if that was the issue…but then again, I can see files that are placed in C:\users\public\video.  I just can’t seem to add new folders.

  3. When sharing a folder, do I have to share the parent folders as well?  For example, assume the files i want to add are located in d:\Media\Video\comedy.  Do I have to share d:\ and d:\Media and d:\media\video… or can i just share d:\media\video\comedy?  I assume it is the later. 

thanks,

Andrew

1. As I am sharing a folder from a PC, will the files appear in the “files” tab or the “Video” tab on WD TV?  I assume the “Files” tab, but want to confirm.

If you are sharing a folder that conteins videos, and you are opening the shares on the WDTV you should go to videos.

The WDTV will categorize the files and will put then on the folder that the belong.

2. My network setting on my PC states I am in a Private Network, so was wondering if that was the issue…but then again, I can see files that are placed in C:\users\public\video.  I just can’t seem to add new folders.

 

If you are able to see that folder, you shold be able to see the new one if they are properly shared. Can you try removing the security on those folders?

3. When sharing a folder, do I have to share the parent folders as well?  For example, assume the files i want to add are located in d:\Media\Video\comedy.  Do I have to share d:\ and d:\Media and d:\media\video… or can i just share d:\media\video\comedy?  I assume it is the later. 

Yes, the last option is the correct.

OK I figured out the problem…I needed to enable the “everyone” group for the folder for it to work.

For some reason my PC only has the admin (myself) as the person who can share the media folders.  Once that was fixed the problem was solved.  I reviewed the directions and that step is not present!

  1. Navigate to the folder that is to be shared. Once found, right click on the folder and select Properties.
  2. Open the Sharing tab.
  3. Once on the sharing tab, Click on the “Share…” button
  4. Click on the down arrow (on the right) to select the option of “Everyone”
  5. Click the “Add” button
  6. Click the “Share” button.

This was the missing step for me which was not in the Windows 8 directions!

Now it is working as designed.

Note: My media files appear in both “File” and “Video” tabs.  I like using “File” versus “Video” to see my list of media as it is significantly easier to understand the name of the file (list versus folders). 

Andrew

Andrewjunk123 wrote:

Note: My media files appear in both “File” and “Video” tabs.  I like using “File” versus “Video” to see my list of media as it is significantly easier to understand the name of the file (list versus folders). 

 

You do realize there is a List View for Videos ?  Which is identical to Files List View

Press the YELLOW button on your Remote Control to change the viewtype.

Thank you, i was not aware of that feature.  I will use it going forward!

Andrew