MyCloud very slow and Freezing - About to give up!

I have a MyCloud 4TB and it have been nothing but trouble since the day I bought. It is veeeeery slow and unstable. If I cycle power I will get 11Mb/s transfer rate that is for 100Mb enet, but I have a 1Gb connection and the led on the back is green so I should be geting better transfer rates. But this is not the bigger problem. The web and App will quit working every 2 or 3 days and then access thru computer will go down to KB/s. Led in the front panel will stay blue, so it dont looks like is overheated. If I cycle power everything go normal for a couple of more days.

I do have a 2.5TB MyBook attached to my router USB port and it works fine, fast and reliable. Also I have a NetGear Stora 1GB NAT and it works like a champ. I replaced all my cables to cat6E and I have 1GB connection on my computer. Also I swapped ports on my router to check if could be a bad port. Got the same frustating result. I do have the App on 2 android phones. I use fixed IP.

I read posts here saying that people got the product working fine, so I dont know what could be causing that. Anyone have a clue what it could be??


1 Like

Which firmware are you on and are you using windows or a Mac ?

(Sorry my enlgish )i have the same problem. i change the router, test on different pc and i still have a lot of inestability and errors. Also, network loses internet connection repeatedly so i change ports and doesn’t work.

Windows 7 Ultimate x64

WD MyCloud firmware v04.01.01-413

Just cycled power again minutes ago. Device had Blue light on front panel, green light on the back network led, but wasnt responding.

Not responding in what, the Dashboard or via a share ?

what are you using to do the transfers? File explorer is generally much better for most LAN operations

Do you have a static IP set? if not set it to static outside the routers DHCP pool?

have you enabled SSH? Are you comfortable with this?

I’m having the exact same problem, with the same system, and I have no idea how to do any of this:

“Do you have a static IP set? if not set it to static outside the routers DHCP pool? have you enabled SSH? Are you comfortable with this?”

Basically, it will connect briefly, then stall untilI reset the unit. Wash, rinse, repeat. I can’t access anything on the device.

Not Responding on both! The Dashboard will freeze… and the share will get slow as a 3 legged turtle… Also the App for android will no longer work

1 Like

I am actually using DHCP…tried static IP before… and I had it outside the DHCP zone too… no changes…always get the same horrible performance! Never tried to enable the SSH…not sure what difference can it make… will try just in case. the funny thing is that if I cycle power on the unit, it will work fine for a while… them get messed up in one or two days…

I use mostly windows explorer and the Android App for WD MyCloud…

I just replaced my router for a newer model… no diference too…

Now it looks like the My Cloud unit is asking for a new firmware update…  v04.01.02-417 …will try that and see what happens…

My New router (Netgear Nighthawk X6) have 2 usb ports and I connected my 2 WD My Book to them and it work perfect and it is pretty fast… so I believe my computer / router / cables / whatever / are working fine… Also I have My old NetGear Stora mounted right beside and it works fine too…

Thanks a lot for all the help and tips…

1 Like