MyCloud performance is nonexistent-- 25+ minutes just to show login screen

I have had this Gen2 1-Bay MyCloud (GLCR) for a year or two. It’s 4TB internal, and then I have three other external drives connected to it.

It’s on a 1Gb switch, to which my closest PC is also connected, and it’s on a fixed IP address. I use it with both PCs and Linux systems, but at the moment, only one PC would be actively accessing it.

Generally speaking, the problem is that the NAS does not work reliably AT ALL and I’ve had some version of this problem since the beginning (I couldn’t successfully target backups to anything on the NAS). Even without attempting to access anything on any of the NAS-connected drives, it will take up to an hour JUST TO RENDER THE DASHBOARD (it seriously does render just a tiny bit every few minutes-- the title menu, then later, the frames, then Device/Diagnostics+Firmware (Health/2.31.183), etc.)-- even just the login screen takes a ridiculously long time to draw. The puzzle then is that the CPU and network usage-- once drawn-- look normal (that is, barely any of either), the front page indicates no issues (last alert was from two weeks ago, related to a power outage), and yet it still takes tens of minutes to respond to any interaction with the dashboard.

From a use perspective, accessing files (especially on the external drives) essentially doesn’t work at all. It can take several minutes to get a directory listing (causing explorer to go to Not Responding), and trying to launch a file (e.g., play a video), can take 20+ minutes to start playing (if it starts at all). At the moment right now, all of my mapped network drives show as being offline-- whether mapped to the NAS internal disk, or the externals.

I ran a Crystal Disk Mark on several sharepoints the other day, and the Sequential numbers looked normal, but the random numbers were sub 1. I’m trying to run it right now but, surprise, surprise, my Downloads folder is on the NAS and is essentially inaccessible at the moment. The problem definitely feels like it’s escalating today-- I’m now getting new errors from Windows (one was about expiring semaphores, and then when I tried again, now it says the “The local device name is already in use.”)

I’ve read a bunch of other posts related to slow performance, but none of the issues there pertain to my situation.

Should I just throw this in the garbage and buy a real NAS instead?

EDIT to update: it was so frozen just now, I had to unplug it. When it powered back up, the performance was appreciably better-- like, the login screen took a normal amount of time, and the Dashboard has (so far) rendered most of the display in just, like, a minute or so… but it’s not yet finished.

Further EDIT: Annnnnd it’s right back off a cliff.

@kauffy How long has this been happening to you? I just tried mine and after about three minutes I gave up. It has never taken more than a few seconds to open up. I suggest giving it a few days and see if it improves.

Update: I just tried it again and in only seconds it was opened. You may want to update your firmware.


I’d say it’s been happening for most of the time since I got it. It’s always been a little slow, but sometimes it just basically stops working.

My firmware version is below yours (..183), though it’s set to update automatically. Right now, it’s saying it can’t contact the firmware server.

@kauffy If you want to update you will have to do it manually. Here is a link to download the update.

Click on: Select your Current Firmware

I found this and was able to download the update based on my current version number. There is a second update, though, and I don’t know if it pertains or not (it’s a .deb rather than a .bin, so I’m assuming it’s a software update).

Installing the firmware update manually worked fine, and now it DOES seem to be able to contact the update server (whether that was a transient issue, or a firmware-based issue, I don’t know). However, it doesn’t say there’s anything else to update. Do I need this .deb file update and/or will it resolve any of the issues?

So far, it seems to be working pretty well…

Make sure to use the correct manual firmware update file for your single bay version. Generally “.bin” files are for the v2.x firmware second generation single bay My Cloud units. Where as “.deb” firmware files are for the first generation v4.x firmware single bay My Cloud units.

Currently the latest Firmware Release 2.31.195 (09/11/2019) for the second generation v2.x firmware single bay/single drive My Cloud units.

Direct download link:

As a troubleshooting step disconnect all USB drives and see if the performance issue persists. The My Cloud like to scan for media/files and sometimes that can kill the device’s performance. One may have to turn off Media Serving on the USB Shares to prevent the My Cloud from scanning the USB drives.

Also note that browser add-on’s and browser plug-in’s can affect the loading of the My Cloud Dashboard. Try disabling them and see if the issue persists. Also try a different web browser, if you haven’t done so already, as certain browsers (like Chrome) may have trouble with the My Cloud Dashboard and the web portal.

This isnt the normal speed?

I left mine unplugged for 2 years. I am sure it would still be copying a single 300k text file.

So ive just formatted an 8TB USB. Im going to ssh in and copy everything to the 8TB then factory reset.

I have 15 Rpi3 and an rpi4. Are there any WDMy cloud emulators?

The Pi can run SAMBA just like the MyCloud does.

What it does not have though, is a SATA port.

I dont understand these reports of “It’s horrid slow”… Mine works just fine. I’ve even done strange “Void your warranty” things to mine, and it still works well.

I have a 4TB my cloud (not sure if Gen 1 or Gen2). . .
I would actually describe performance as “snappy”.
It works fine wirelessly from my laptop and a tablet.
Heck. . . it works fine from across the globe. . . hooked in via VPN. . . but limited by my &^&%$ing ISP upload speed.

This smells like a network communications issue. . . I wouldn’t guarantee that buying another NAS will resolve the problem.

A few things;

  1. The last few firmwares seem to have been fairly stable. . . If you are talking about firmware 1 or 2 steps back. . .I probably wouldn’t have high hopes firmware will fix it.

  2. Is there any media scans or “Chkdsk” scans running? Those can really slow things down.

  3. Do you have access problems with ALL PC’s. . . or just one? I recently had a Win10 update “compromise” access to a network device (an EX2 ultra. . .this issue did not impact the MyCloud). Took some serious troubleshooting/fiddling with adapter settings to fix.

  4. Are the devices in the same Windows Workgroup? (easy to goober up). I once had things on different workgroups. . .and that really fouled things up.

Are they on the same IP subnet? (harder to goober up) I know it took fiddling to get the EX2 (on to read a VPN PC on (

Is SMB1 enabled? (this is now set disabled by default).

  1. Disconnect the USB drives. . .maybe something is confused?

  2. I would not rule out router or switch problem. Try plugging both units directly into the router. Try a different switch PORT. Different LAN cable. Different router if you have one.

Just some thoughts.