MyCloud Device Disconnects Itself from the Network Daily

I’ve got to say I’d hoped that I would not get stuck with this issue.  Well two days owning my 2TB with updated firmware and it’s disconnecting.   I’ve already got a static IP and shutoff sleep.  I’ve got no media sharing turned on and only using this on a home network wired directly from router to PC’s.   The only way I can get it back is by unplugging it.  I’ve got 10 days to return it so if no solution is found in the next 5 or so this thing is going Buh Bye!   Shame on you WD!!   

*Exactly* the same problem.  Netgear R7000 router, Windows 7x64.

I have 4TB. I have exacly the same problems. I am get tired of resetting this device. It’ s not stable. I was expecting to restart yearly. Now I am daily restarting it. And sometimes it’ s still not accessible after restart.

It’ s network is dropping. It seems running with it’ s blue LED, but you can’ t access it.

Please help… 

I just purchased a 3Tb My cloud.  Transfered 100Gb of Photos to it went fine a little slower than expected.  I noticed a few disconects when connecting via Mobile devices. Now I am in CA and my device is in CO and its disconnected from the Net I cannot access. Help please I have important data I want to work on and will not be there for 30 days to hard reset the device. How can remote reset this device…Help Help Please

Hi JosephNg - thanks much for that tip, I stopped those two server processes following your instructions and my load average dropped from over TEN quickly averaging down to 7, a big drop. (Still a high load for this tiny box)  

The processes that are taking the most time are rsync, perl, afpd, and apache.   (afpd is probably apple file protocol daemon)   note that in this process snapshot i have already killed those processes you mentioned but am simultaneously creating a SafePoint to an attached USB 3.0 drive.  Surprised to see so much time allocated to the two rsync commands though.    forgot off the top of my head the command to list processes sorted by cumulative processor time and/or memory but really very much appreciate you pointing this in the right direction.  Will post later to see if this has a lasting impact.  cheers…   nick_nyc


19733 root      20   0 30976 1392  228 D  33.7  0.6 681:31.35 rsync

19731 root      20   0 22180 3952  312 S  24.5  1.7 642:17.58 rsync

18931 root      20   0  9644 1576  492 D   4.6  0.7  14:48.59 perl

  378 root      -2   0     0    0    0 D   3.6  0.0   1:46.40 btn_t

17941 root      20   0     0    0    0 D   3.0  0.0  48:51.06 usb-storage

10299 nick      20   0 18260 1484  512 S   1.3  0.6   1:18.65 afpd

17538 root      20   0     0    0    0 S   1.0  0.0   0:00.99 kworker/0:1

    4 root      20   0     0    0    0 S   0.7  0.0  21:44.21 ksoftirqd/0

  278 root      20   0     0    0    0 D   0.7  0.0  23:58.64 kswapd0

18007 root      20   0     0    0    0 S   0.7  0.0  12:50.08 flush-8:16

JosephNg wrote:

Finally, I use the following method to make the disconnect problem gone.


After restart the device.

login SSH and type the following two commands

/etc/rc2.d/./S85wdmcserverd stop

/etc/rc2.d/./S86wdphotodbmergerd stop


My device run very well for more than 3 weeks (except that I cannot view photos from “WD photos” iphone app)


Obviously, there is a bug in wdmcserverd and wdphotodbmergerd services.

BTW - I previously and methodically turned off the DLNA and iTunes server functions from within web interface and set up a static IP (each of these steps one by one waiting a day or more  in between) and none of these solved it, though each did seem to help a bit.  I can report that the drive is already acting more responsive, though since this seems like a memory leak or cpu creep issue it may take some time to confirm.  I also had previously tried raising the unit up a bit using tic-tac boxes under the front and rear rubber feet to encourage air circulation under the unit since it seemed to be getting surprisingly hot.  (that didn’t work at all) 

Scraig wrote:

 How can remote reset this device…Help Help Please

You can create VPN tunnelling for SSH. Then you can remote access your device’s dashboard as if you are in your local network.

Same problem here (2TB).

Installation went fine… file transfers as well, untill disconnecting. First time I turned the power off /on, that worked. But after the second time I Send an email to support (wasn’t aware of this forum yet), then I send a reminder, then somewhere in june I got the response to reset the device and to change the IP into static.

I did it yesterday, but this morning already no connection possible…

WD solve this problem please…!!

We released a firmware update today that should fixed this issue.  I am closing this thread as fixed.