MyCloud autoremove


I’m newer in this world.

I have tried to install on WD My Cloud Transmit for the torrent download; a procedure on the web saying that at some point I had to get autoremove apt ; l ’ I did it ’ s execution of this command I 've formatted or quantomento removed the packages needed to start the operating system .
Now , when I turn on the device , the alight remains white and the myCloud no signs of life .
What can I do? Please help me.

hello Antonio:)

first off try to do 40s reset… turn off the device (plug out power cable)… press and hold reset button and plug the power cable back in and count to 40 and then release the reset button…

Hello mefistos :slightly_smiling:

Thank you for the reply to my questions. I had already tried to reset my cloud but nothing happen. The light rest solid white.
Other ideas?!?! Help me please!

Thank you!

If you have tried to use apt to get or install packages from standard linux repositories, then it is likely that you have damaged the Linux installation on the v4 firmware MyCloud; it is not a standard Linux build, since it is built using a non-standard 64k page size, unlike the 4k page size of standard package repositories (and v3 firmware MyCloud).

This is the danger of blindly following instructions found on the internet without understanding the platform you are using, and whether the instructions are still relevant. It’s also why WD say that using SSH may void your warranty…

So you need to search for ‘unbricking’ guides on this forum.

If you manage to unbrick your device, look for the thread here on how to install Transmission for the v4 MyCloud firmware.

thank you cpt_paranoia…

Can you suggest me some guide to unbrick my cloud?

Thank you so much

you will have to take it apart… here is a video how to do it … .then you will have to connect it to PC running linux ( Live CD ), here you need either SATA to USB cable or stationary computer where you can switch the MyCloud HDD with your HDD… then you can follow this guide How to unbrick a totally dead WD My Cloud (I unbricked my MyCloud twice thanks to this guide :slight_smile: … )

1 Like

The direct link to the guide is this: [GUIDE] How to unbrick a totally dead MBL ???

Thank you so much I will try and reply to this topic!

yes… the guide is throughout the whole post :slight_smile: first few posts are the most important… if you need any help let me know :slight_smile:

1 Like

Thanks a lot!

mefisos I had made the procedure but the led rest RED now. This is the steps that I followed.

What can I do?


Hello again Antonio:)

so lets take it from beginning… you have connected the HDD to another computer and then you booted up to linux where you used gparted to rewrite both (yes you have to rewrite both of the 2GB partitions) partitions with the img downloaded from the other thread and still it doesnt work? I had same red LED but it was because of a critical warning in dashboard but the disk itself was working

Thank you mefistos,

I put the and image on thumbdrive and i started a pc from cd with linux. Next I had connect the HDD to pc and I executed the script in case of delete all content (the wd cloud was empty). The script work without errors but when I connect the my cloud to internet by the router I don’t reach the cloud from the url http://wdmycloud.local/UI. The led on nas rest red. Before to start the process i had to format the hdd in fat32 with one partition.

Hint? Any idea?

Thank you so much!

That is the wrong unbricking guide for a My Cloud, the link in your post goes to a My Book Live unbricking post which is a different WD drive and may have different unbricking procedures and use different files for the unbricking process.

Use the link from Mefistos post:

no… wrong guide… follow the guide I and bennor posted How to unbrick a totally dead WD My Cloud … you just boot to linux open gparted… rewrite the two partitions and thats it… you probably used wrong .img files

1 Like

I think that was a mistake… You don’t want to go near the device with a FAT32 format, as it needs to be a multi-partition ext4 formatted drive.

There’s a thread somewhere in the forum on how to replace the hard drive on a MyCloud with a new one; I think that might now be the guide to follow, as you have destroyed the partition scheme on the drive, and will have to recreate it. Bennor might be able to point you that way, as I think he’s done it. Or Ralphael.

Probably this thread:

1 Like

oh my god… I didnt see this part… well this is bad… I believe there is way to recreate the HDD partition… I have seen only 2TB version but you can then stretch it to 4TB…

EDIT: How to unbrick a totally dead My Cloud? this is what I am talking about and this Here is WD My Cloud 2TB virgin disk image it might work… it will definitely work but it will take some time

EDIT2: antonio give me a minute I will try to make a 4TB version for you so you can just dd if=image.img of=/dev/sdb the image…

1 Like

What command do you use to create that image? I think it might be nice to have lying around, ‘just in case’…

1 Like

Thank you!!

This one dd if=/dev/sda of=/DataVolume/shares/Public/mycloud.img bs=1M count=5000 :slight_smile:


Great mefistos I’m waiting for 4tb img! Thanks!