MyBookLive Windows 10


#1

I have been using MyBookLive for several years.

I use is as a backup for my PC running Windows 10.

It was mapped on to my network as Z drive. Connected to my PC via Ethernet cable.

All worked perfectly until October 2018 when the Z drive disappeared.

I am satisfied the MyBookLive is working OK. It seems the problem is it working with Windows 10.

Several calls to WD support (in total probably 10 hours at least) have failed to resolve the problem despite being escalated to “Level 3” status.

Today I was advised by WDC support that the only option would be to take the drive to a third party data recovery option.

My thoughts are to “trash” the MyBookLive. So I am on here has a last resort. Therefore any suggestions would be appreciated.

In the meantime I purchased a Seagate 4TB portable hard disk that I am now using for backups. It works fine; plus and play through USB.

Any thoughts or suggestions would be appreciated.

Paul in Australia


#2

I’ve got no suggestions but I’ve got a few questions.

Can you access the MBL dashboard via a browser?

You say the MBL is (was) connected to your PC by an Ethernet cable. Is that directly or through a router? If through a router, does the router see the drive? Can you ping the device?


#3

Yes I can access the MBL dashboard via a browser.

MBL connected direct. Yes it shows up on Windows. The problem is that Windows can’t or won’t connect to the drive.

I have spent many hours with WDC support staff. The problem was escalated to level 3 but could not be resolved.


#4

Have you tried enabling “SMB 1.0 / CIFS Client” as mentioned in this thread?


#5

I did exactly as you said but I still get the message that Windows can’t access MyBookLive


#6

For what it’s worth, I have SMB 1 disabled on Windows 10 and have no trouble accessing my MyBookLive via File Explorer. Microsoft disabled SMB 1 for valid security reasons. There is usually no reason to enable it.

Some flavor of network discovery used in Windows does not work without SMB 1 so the NAS may not show up in Window’s list of networked devices, but if you know the IP address or name of the device you can access it.


#7

I am having the same problem