My WD Passport Ultra is very sick... and I need help!

Greetings all,

First I will confess that I have been lurking on this forum for several months, and have found solutions to many of my issues/questions by doing so.
So this is a formal Hello and introduction, as well as my first post!

The WD drive I mention in the title of my post has just recently started giving me fits. It is so very,very, slow. By that, I mean it’s very nearly nonfunctional. And this is unfortunate because it is my backup drive. It is a 2TB drive that I bought specifically for backups of my internal drives.

I recently got hacked and wound up getting help from an Anti-Hacker forum. I did a backup of my data once we felt my desktop was ‘clean’. Then I formatted my hard drive, and did a clean install of Wndows 10.

I was preparing to use an Acronis Boot DVD and do a restore of an image backup of my data partition. Acronis looked for the external drive for about 30 minutes, found it, then I clicked on the ‘Browse’ button to select my backup. After waiting for almost 2 hours I gave up.

I had also made a backup of my data partition using Paragon Disk Manager Suite, so I tried it. Essentially, almost the same results. I did actually get to my data backup folder with Paragon, but when I clicked on the folder it hung.

My primary HD is a WD Black 1TB drive, and I used the WD Drive Utilities and the Data Lifeguard Diagnostic for Windows hoping I would be able to resolve the problem.

Neither of WD’s tools found the Passport as a physical drive. I used HD Sentinel and the first time it said the drive had several errors and told me to run the test again. When I did that, I just got a ??? for the drive.

I have to get that backup so here’s what I’m doing:

In Windows Explorer (and several Explorer replacement tools) accessing any file or folder on this drive just causes a 30 minute hang. So I’m using Directory Opus (in case you’re not familiar Opus doesn’t use Explorer to perform it’s file management). with the drive attached to my laptop, and deleting files that I don’t HAVE to keep, and moving files to the laptop drive C if I need them.
I’m using the laptop because I started thinking I was having issues with my desktop when this problem began. Windows was very slow starting up and shutting down…

Sorry this is so long, but wanted you guys to know all that I’ve tried. It is very slow deleting/moving files from the drive but it’s actually getting a bit faster as I get more data off the drive. But get this - It’s a 2TB drive and it had 1.2TB free. (it’s still incredibly slow)

Even if I manage to get thru this and restore one of my backups from the drive, it’s going back to WD for warranty replacement. It’s only 6 months old.

Any of you know of another drive utility that I might try? I’m attaching a couple of screenshots to give you an idea what I mean when I say slow! Well, I guess I won’t be attaching screenshots. I don’t see any option for attachments. I’ll just give an example: TeraCopy was trying to copy my data backup to another drive I have. The data backup is 194GB, and TeraCopy showed it would take 122 days and 6 hours to copy it!!!,:weary:
The screenshot would have been more dramatic…

I’ve made some progress - meaning I’ve gotten quite a bit off of the drive. It’s not quite as slow, but still too slow for either of my backup software to pull up the archive.




My recommendation is to get the data out of the drive an test the unit using the WD Dlg tool. Also, once you get the data out of the unit, try reformatting the drive.