Troubleshooting suggestions requested WD Passport Ultra

Hello all, I’m trying to rescue the data (about 160G worth) off of a My Passport Ultra.

-Drive is password protected, and will unlock after a few seconds. Folders and files appear. Opening and copying a file is super slow.
-Tried to copy one of the folders last night, about 1G came over in about 6 hours and I’m not sure if all the files came over intact because browsing the drive locks up the computer. Files that do appear on the copied folder open as usual.
I tried downloading the WD drive utilities. Sometimes it can see the drive, but the utilities fail. Sometimes the program cannot detect the drive.
-System is a brand new Win10 Pro, on an older (~1year) Win10 laptop the same issue occurs.
-Current machine says there is a driver issue (but then wouldn’t the drive not even appear?)

I tried downloading a different copy utility (TeraCopy) but it is still just as slow.

Any suggestions of the next thing to try? Every step takes hours with this super slow drive, so I hope to guess right on the next thing.

Thanks for any help/

Hi @jolene,

If the test result shows drive failure, we suspect that drive is faulty.

We suggest you to plug the drive into a different USB port and using a different USB cable and try to connect the drive to another computer.

Also, please contact WD for Technical Support for drive warranty and replacement:

The test fails, as in the software fails. Do you actually have a test or other utility that will analyze the drive itself?

Have tried many ports on two different machines, and as I mentioned two different operating systems. Only have one cable though.