My WD elements is not accessible - freezes file explorer

My WD elements 2TB was plugged in my pc for some time and a few days ago i wanted to unplug it from my pc but i couldn’t do it on a safe way because i get a pop-up that the system is using some files from the drive. I checked but i didn’t found any file open which is used from the external drive. After this, i unplugged the external drive in unsafe way. However, afterwards, it never worked again when i plug in my external device in my computer nor on my laptop. That is, when i plug my device in, i can see a D: drive pop-up but thats it, when i click on it to open it, my pc and file explorer freezes. When i unplug the external drive by file explorer gets back normal. Same happens on my laptop. When my external drive is plugged in the light keeps blinking. when i use different recovery tools they get freezed when i plug in my external drive to read it. Sometimes when i unplug my device i get the error message: "the D:\ is not accessible. The parameter is incorrect.’.

I already ran the command prompt CHKDSK /d D: but there I got keep getting an error in CMD that there is not enough space for storing some batch file. This is rather strange since the capacity of my external drive was far from fully occupied.

Also when I click on properties of my D: drive there I see the following:

Device USBSTOR\Disk&Ven_WD&Prod_Elements_25A1&Rev_1014\575833314142384C44355434&0 was not migrated due to partial or ambiguous match.

Last Device Instance Id: USBSTOR\Disk&Ven_Generic&Prod_Flash_Disk&Rev_8.07\2122B540&0
Class Guid: {4d36e967-e325-11ce-bfc1-08002be10318}
Location Path:
Migration Rank: 0xF000FC000000F120
Present: false
Status: 0xC0000719

When i view the event logs, i can see also the following errors:

Damaged block in device \Device\Harddisk1\DR21

And a warning message about some new attempt was made for IO-operation on logical blok.

Now almost every time when I plug in my external drive to my computer it freezes file explorer when I open it. When I unplug it everything gets unfreezed. I dont know whats wrog here. Thanks for any help.

Chenchela…sad to say, but I think you have a Big Problem. Unfortunately, you forced unplug the USB when an App was writing to it or a Backup was writing to it or you were downloading movies in the background…with these USB connectors, the best way is the safe way either using the rt mouse, on the drive to Eject…or Safely Remove a Hardware icon in the lower tray…Now you did this correctly, but pulled the USB after notification of use.

I had a similar problem with Explorer…on a file/folder on my PC. I tried to Explorer delete a file that was opened in a movie player that was minimized. Somehow I kept trying to repeat the delete and soon found myself with a strange display. When I opened a different large folder, I could tell something was wrong because the green search bar would be progressing across the top of the window…and my thumbnail display would not show, only the detail view of the files worked. I would eventually get a ‘Not Responding of Explorer’ message. Restarting my PC got the Explorer to work fine, even on Thumbnails…BUT, if I went back to look at that one file, either to delete, rename or move I created the same problem again…so another restart.

I took the PC to Best Buy Geek squad (I had a service contract when my PC power supply died and bought a new one 6mo ago). Explained (social distance) the Explorer issue. I bought a another Passport HD for them to copy necessary files, in-case they had to wipe the drive because the OS was bad. They claimed that they found a malware and everything is now good…BUT, couple of tries with the same file produced the same results.

For me, I was able to pull/copy/remove everything but the bad file and saved the good stuff into another folder. I now leave that bad folder alone and so far…knock on wood! I made sure my Passport Backup ignored this bad Folder too.

Now for you, disconnecting the HD seems to get your Explorer working as long as you DO Not view the HD. Mine was my internal drive so I had to restart the PC. I think when you attempt to view the HD, Explorer is searching for something that it cannot find rather than a bad spot on the drive.

Unless you are a real Tech type of person (you ran chkdisk and properties), you are going to need either an external disk application fixer for the drive (I have System Mechanic, but when I ran on my PC, nothing showed up…even after running its Malware App). I don’t know of one…check the internet.

Since you need that HD’s data, you are needing help. The Best Buy Geek Squad is a simple approach, other than if you can fix it yourself. You pay for service or purchase an annual fee, which kinda gives you a free evaluation and repair…you may have to buy another HD so that they can transfer data prior to clean. At least its a HD that you can take in and when they plug it in and run Explorer, should create the same problem…hopefully…However, if it’s a bad file like mine, they are not going to able to find/delete/or partition off from the others… Unfortunately, you don’t know what file was the problem…

You said that as soon as you plugged in the HD, Explorer hangs up even if you try to open something from your Internal drive and not touch the HD…sorry I got so wordy, I’ll quit typing…but something like this caused me grief too!

Hello there, thank you for your extensive response :slight_smile:
Still trying to figure out the solution, I opened the HD but everything seems ok at first glance. The Drive is by te way not that old so its as good as new from the inside.
The heads where at their place and nothing noticeable on the PCB. Hmm, now I suspect the USB cable.

chenchela…so you opened the HD…I don’t like that approach, not sure what you were looking for other than broken pieces. The problem is more interface or software…

I was reading on a completely different blog about a similar Explorer issue with an attempted fix. I couldn’t really follow but others get the same problem, of a hung Explorer, using different products. If you are on a PC…anything could happen…
https://groups.google.com/forum/#!topic/video-downloadhelper-q-and-a/csRr5PmLdtM

You really need to take the drive somewhere. I used the BestBuy Geek Squad, pay for the support and try if someone can help…or try what you are doing to look for some online or other help. Don’t know how much Good Stuff you have stored either.

“The Parameter is incorrect” is one of the common issue related to external drives which may leads to 2 major issues:

i) Cannot Copy Files
ii) Drive becomes inaccessible

“The parameter is incorrect” issue can occur due to various reasons like Virus infection, Unsafe removal of hard drive, Power failure, Bad sectors, and Corrupt file system. Though the issue can be resolved; below are the few possible solutions to fix the issue:

  1. Run CHKDSK
  2. Run SFC Scan
  3. Use Antivirus Program
  4. Format the external drive

Further, you can check the below link to know the detailed process to fix the issue:

Hope that will help!