WD Elements external drive not accessible

I have a WD Elements 1T external drive that I don’t use much and that is pretty full of backed up files. It was working perfectly until I connected it to my old Lenovo. I was checking some file and tried to delete some of those. However for some files (which were not opened) I got the message that they could not be deleted. The PC became slow and in the end I turned it off with the external drive still connected. I then disconnected the drive and tried to connect it to my new Lenovo. The drive is being recognised: I hear the Windows 10 connection sound, it shows as Local Disk in File Explorer, it shows up under Device Manager with its name WD Elements and, after a few moments, also in Disk Management but just with its letter H:) . The problem is that but I cannot access it in File Explorer and the light on the drive keeps blinking.

Any idea on how I can solve the problem without formatting? Could it be something related to the file system?

How do I check that?
And does it really matter at this point? The drive is not working on both computers and I am trying to find a solution from the new one which is more powerful and can handle the possible recovery better.

I think the issue is with the file system that is compromised. When I try to open the drive from File Explorer I get the message “H: is not accessible. The parameter is incorrect”. And when I try Error Checking from the drives Properties I get “The disk check could not be performed because Windows can’t access the disk”.

In some cases, storage device is not properly connected to computer and it cannot be recognized, for example, there might be something wrong with power supply, cable or USB port, etc. You can try the below solutions:

  1. Check the USB port
  2. Update the disk drivers
  3. Partition & Format the drive

If none of the above methods work then there are chances that your drive may become RAW. There are various reasons for this issue such as BIOS settings, USB data line, USB interface voltage variability, drive hidden issue, or compatibility issue, etc.

You can try below options as a solution for this issue:

  1. Establish a connection between another system and USB Data Line to verify whether it is broken or not.
  2. Make sure the system and motherboard are compatible with each other.
  3. Verify whether the USB interface voltage is up to the mark or not.
  4. Use Disk Management to unhide the drive.
  5. Ensure USB is enabled in Operating System as well as in BIOS.

Hope it helps!

1 Like