My WD Cloud

l have 2 2TB my cloud units. The clock on them are not syncing with or with Windos11 pc’s time. Currently there is a difference of about 10 mins. I have tried the to sync with the time server ( it is set to do it automatically). WD says to automatically sync. Neither of my Cloud drives are syncing to correct time.

Any suggestions to overcome the issue as official support is no longer available for this device😒


Are both devices My Cloud Homes? If not, then give the make and model of the My Clouds you own and their operating system. The image below is from my 2nd generation WDMYCLOUD OS5.

Is your computer + or - to your My Cloud? How old is your computer? It could need a new CMOS battery if it’s minus to your My Cloud Home.

Both are old models run os3. That’s why it support won’t help me. bummer. I have already tried what you have high lighted. no response from the device. Both are 2TB WD cloud home.


My computer in SurfacePro 5. Its CMOS battery is fine and it keeps time very well.

I have a MyCloud unit. I’m not sure if it’s 2 or 3 Tb. The only information I’ve got is from the two labels on the unit, giving the MAC Address and they P/N and M/N

It’s working fine, normally accessed through my iPad and from time to time my PC and my LG Smart TV…

Since Western Union pulled out of supporting MyCloud I have used FE explorer as my way of accessing it and using it as a nice big extra storage for my iPad. I don’t have remote access anymore, but that’s not a problem to me.

But now I’m having problems setting it up to connect to my Smart phone, a Doro 8500, again using FE Explorer, but this time with a version loaded from Google Play Store rather than the Apple App Store. With the Apple version and my iPad the app gave me an option to automatically have a connection with all devices on my home network, one of them being the My Cloud, but I don’t get that with the phone FE Explorer, and I’ll have to do it manually.

It looks as if I could connect manually, but I’d need to put in the Server URL, and I don’t know what that would be. if anybody can advise me how to proceed, that would be handy. I’d like to be able to manage my MyCloud from my phone, and use it as extra storage.


re advice:

  • Buy a newer and more secure network storage device than the 10 year old unit you have
  • Don’t buy it from Western Union, WD is okay.
  • Come back and if still using OS3, post in the correct subforum in order to get better readers and answers

Probably sensible advice, but I’m happy with the unit itself, it’s just that I’d like to have access to it from the phone while I’m around the house. Distant access isn’t required.

My ruling principle is “if it ain’t broke down fix it”. Brand new, ten years old or a hundred years, what matters if it does tge Jo to my satisfaction.