. The date on WD My cloud is wrong. Unable to sett the date

The date on WD My cloud (4TB) is wrong.
Unable to set the date. It doesnot update.
Time zones are correct.
NTP is not working. Turned it off. Still unable to set the date manually.
Time is updating.
Running on latest firmware
Kindly help

I have two My Cloud gen 1 systems one on 04.04.02-105 and one on 04.04.05-101. Both systems
have the correct time. They are set to EST.

More information is needed.

What My Cloud firmware are you running?
What time zone are you in and which time zone are you selecting?
How far off is the time?

Providing the information asked for by Bennor will help.

Are you sure you set everything up? Are you connected to the internet and have cloud access? Provide images if possible.

See image below. Click on, tap or activate image to enlarge it.

Dear Bennor https://community.wd.com/users/bennor and cat0w,

Thank you for your reply.
I am currently running on WDMyCloud v04.04.05-101. That is the latest
I am presently in India (+5:30)
The date is one day behind.
I am connected to the internet. I guess WD has no problem connecting to
internet, as it is checking firmware version and saying it is up-to-date.
I am able to set time correctly. But not the date.
When I pick the calendar tool to set the date, the calendar shows the WD
date (wrong date) and Correct date (Probably it is picking that from the
computer) as highlighted. But when I pick the correct date ( any other date
for that matter) doesn’t get reflected on the system.

When I attempt to change to any other time zone, the date also get changed,
but still 1 day off for the new time zone.
My guess is that, somehow, the internal clock, which gives GMT time is
running one day off and something is preventing from updating it.

Mean while I tried first level system restore, but not of any use.

Please see screen shot of the UI attached along with.

Hi Bimal

I am running my WD cloud in the same time zone and it seems to be working fine. Here is the screenshot of my cloud

In the screen shot, NTP Service is set to off, any particular reason you have it set to off?

Enable NTP Service then see if the time syncs. One can also add their own time servers by clicking on “Configure” to the right of Primary Server.

Also check your local network router to see if it is using the correct time just in case the My Cloud is pulling the time information from your router.

Dear Bennor,

NTP was set off, because it was not working.
It was not syncing to right date and time even after keeping it ON for
days. It was always connected to internet. The system was able to check the
firmware update, and that means, it was able to communicate to internet.

Do you think it is an issue with the hardware?

Dear Parambir, https://community.wd.com/users/parambir_singh

Thank you for the update.
Are you running the same firmware?
If so, then it may be a hardware issue with my box.

Yes I am running the same firmware as yours. Could you resolve the problem?

Yes. I was able to solve the problem by simple ‘date -s’ command through
SSH. I think the issue is with the firm ware UI. Also my onboard CMOS
battery seems to be dead.

Mean while the WD support team told me that the only way to solve the issue
is by complete reset as the system only reset didn’t work.

But the simple date command solved the problem.

what does that mean in English?

i have NTP on, with the right Time Zone
… and my date is 5 days earlier and time is off

i have the latest firmware update

Dear Shivs,

I think it is a bug in the firmware or UI. Once the CMOS battery which is
keeping the internal clock updated is dead, the firmware does not update
the time from NTP.
Also in my case, the UI was not updating the clock when I tried manual
However, you can solve the problem partially by updating the clock using SSH
The steps are as follows.

Login to your WD using the UI and enable SSH
Download an SSH client, like PUTTY
Login to WD through PUTTY (Login: root Password: welc0me (default)
Issue the command

date --set=“4 APR 2017 15:55:00”

Correct the date and time.

Log off from Putty

Now onwards do not shut down WD as the clock will not be updated. In case
you shut down, you will have to repeat the process to update the time.

Not sure the single bay My Cloud units have a CMOS battery. An example of the single bay (first generation I believe) My Cloud motherboard:



In any case one may be able to trigger the Linux command to update the date/time from an NTP server via a boot script. For the v4.x single bay first gen My Clouds one can trigger certain Linux commands at boot in the /etc/rc2.d/S98user-start file. For v2.x single bay second gen My Clouds one can trigger certain Linux commands at boot using CRON.


Thank you Bennor,
You saved my box. I was about to open the box to check the CMOS battery.
But how was it keeping the time?
I remember it was showing correct time even after keeping it off for

Either a backup capacitor, or getting time from an NTP server.

Generally it will use network time protocol, if NTP is enabled through the My Cloud Dashboard > Settings > Language & Clock > NTP Service = On. Or if one has NTP Service set to Off they can manually configure the date/time by selecting Configure to the right of My Cloud Dashboard > Settings > Language & Clock > Date &Time. If NTP is enabled it is typically updated when one powers on the My Cloud or reboots the My Cloud. I think the My Cloud firmware may also update the NTP time once a day as well. If NTP is off there is probably a capacitor or EPROM which is used to backup the time when the My Cloud is shut down or rebooted.