My password!

good evening gentlemen,

i hope that you can help me.

i have a wd hard disk (my passport 0730), everything was ok for two years of using.
last days,i wasn’t able to use it, i try it in others pc and laptops and didn’t work.
i download wd program . and i found that the hard disk asking for a password to unlock it…
i never use a password and i don’t even remember if i pick a password for the hard disk.
would you help me please…
i have important files i need it for my work.
by the way the light is on and my laptops can see the hard disk but it cant open it.

Have you tried updating the firmware on the unit?  

dear  John012

i found this page 

to update the firmware.

but they say :

  • Before updating the firmware on your drive, make sure you have a copy of all the data on your drive stored on a separate device.

is that mean if i update the firmware , all data will be deleted !!

and thank you for responding .

No, but it means that if things go wrong then you could make the drive inaccessible (e.g. if power is lost or the drive unplugged during the procedure), so where possible the data on it should be backed-up in case of problems like that. 

I’ve done a couple of firmware updates on my WD kit and not had any issue with it, nor lost any data. But it’s just there as a warning.

sadly…i try and didnt work…

even the updater ask for password.

i am so confused.
it’s been a month for this problem .

but i won’t lose hope …


any respond??

any solution??

also is there any way to recover my data???

i swear i didnt put any password…

i put all my life in this hdd

my married photos,vedios,work results,over 2000 songs,and there is more…

please help me…

I presume you’ve tried the password hint tick-box and it’s not giving you any insight?

Aside from that I’ve no further ideas, sorry.

and that what make it absolutely a bug for wd co.

password hint do not show any thing .

if i put a password i always use password hint…

at last could some one tell me how to recover my data???

whats hurt the data is fine and exist n hdd but i cant open it.


i am so sad.

didnt find any thing toopent it…