My password suddenly does not work! pls help!:(

I have 320GB WB passport external drive bought in 2010. I use it everyday until just today I try to unlock my external drive with my same old password but it just does not work!! I tried so many times but it kept saying my password is invalid. IT IS NOT POSSIBLE as I’ve never changed it. Now I’m so frustated as there are tons of data about my work and my study there. Could anyone pls pls help suggest what I should do and explain why this happened.

thank you very much



Well there are only 2 things to try. One try accessing the drive from a different user account like the guest account. The other is try a different computer. There is no reset or workaround. The drive is hardware encrypted so don’t waste your time trying to remove the drive from the enclosure any data recovered that way will be encrypted and useless.


1 Like

Thank you very much for your suggestion. I will try and let you know whether it works or not.


I have tried with another computer but it didn’t work either.:(:frowning: what’s wrong with this WD drive!