My Passport Wireless doesn't copy SD cards since FW 1.06.06


when I bought the disk earlier this year, I was fully satisfied whith the whole functionality. Copying SD cards worked fine. I lved the incremental backup function, which I missed at other products.

Since upgrading to the latest FW, copy SD card does no longer work. Used the same card as befor, following the same procedure as before. Did everything like described in the documentation. Autimatic and via the GUI, both ways doesn’t work.

Any idea?


It could be a coincidental hardware failure related to the SD card slot. I’d recommend contacting WD Support about this. If the issue is hardware-related then they’ll be able to replace the unit for you.

New drive here and 2 of my older SD cards (both 16GB Transcend) won’t upload–says there are no cards detected. Before I gave up, I tried my 2 32GB Sandisk cards and both will upload. I could find nothing indicating there were problems with some cards but glad i tried all of them,