My Passport Ultra suddenly not letting me transfer anything to it from my MacBook Pro

I bought a My Passport Ultra for my MacBook Pro 13" along with purchasing the computer back in October or November of 2015. I started using the passport right away by plugging it into my old PC to transfer all my photos to the passport. Then I plugged it in to my Mac to transfer some of the photos/documents on to the new computer. It’s worked perfectly fine ever since. I few days ago, I used my old PC laptop to transfer photos from my SD card onto the passport. Today, when I tried to do the same thing with different photos using my Mac, it didn’t work. Although my Mac still recognizes it and allows me to look at files/photos already on the passport, it doesn’t seem to let me transfer anything to it. I went into Finder and clicked “Get Info”, which told me that my permissions were “You can only read.”

Can anyone help me? I’m new to both Macs and Passports… I read that I might need to reformat the passport to get it to be compatible with Macs, but I don’t have anywhere to put the stuff on my passport while I do that, and it’s certainly not stuff I’m willing to lose.
Any help is very very much appreciated!!


If the drive is formatted NTFS for Windows then Mac will only be able to read from it. If you want to be able to write to the drive from your Mac computer then you will have to format it HFS for Mac, but this will delete all data from it and then Windows will not be able to read or write from it.

In order to use in on both you can format it as Fat32 or EXFat.


Thank you for your response! Is there a way for me to tell how it is formatted?

Thanks again!