My Passport Ultra drives do not work with Time Machine ENCRYPTION

Just wanted to note that the “My Passport Ultra” drives DO NOT work with Apple’s Time Machine feature IF encryption is selected. I tried two of these drives and both failed the same way when Time Machine was attempting to initialize encryption. It gets about 90% of the way into initializing encryption, then fails every time. I tried the same process with a Seagate drive and it worked fine. The “Ultra” drives DO WORK with Time Machine IF encryption is NOT enabled. Both of the “Ultra” drives I tried were 3TB. Both drives were formatted with Apple Disk Utility to “OS X Extended (Journaled)” and a GUID Partition Map per Apple’s guidelines.
The error messages I received during the encryption initialization process were “There was an error preparing the Time Machine disk. Couldn’t mount disk.” and then “The disk you inserted was not readable by this computer”.
Platform: I am running Mac OS X v10.11.3 (El Capitan) on an Early 2009 24" iMac. The “Ultra” drives were connected to a USB 2.0 port on the iMac using the USB 3.0/2.0 cable supplied with the drives.


I recommend you contact WD support directly in order to get assistance with this.

I think the same thing happened to me. I did my first backup, applied the encryption option, it took all night, and when it appeared to be done I could not eject the drive. OSX kept telling me some process was trying to use it. Tried logging out and in and that didn’t work. I just ended up detaching it. Now when I connect no drive shows up at all. It powers on, it hums, but no communication with the OS.

Did you end up finding a solution for this? I just did an OS update and that changed nothing.

With the 3TB Ultra drives, I did not even get as far as you did; they would error-out about 90% of the way into the encryption SETUP process (20 seconds or so after clicking ‘encrypt’ and selecting the drive). But 2TB Seagate drives worked fine. I just installed a new 3TB G-Gate external last night and ran a full Time Machine backup on it. It is going through the multi-day encryption process now. I’ll let you know if/when it completes.