My Passport SSD weird issues

OK! So I am having an issue with my new "My Passport (1Tb) SSD. I have not dropped it, has no visible damage, and I got it as a Chrismas gift (was told it was bought from Best Buy).

I open up the box and plug it into my PC that has Windows 7 and I get a message saying that it sees the drive but it cannot use/open it. I go to the website (WDC Support) and it says to try it on another computer. I go to my laptop that has Windows 10 and it pops up perfectly. I saw there were files on there from WDC and I don’t think anything of it. I read on the website (WDC Support) that I should try formatting it. I format it no problem. I then go back to my PC (Windows 7) and it now won’t even give me a message saying it can’t open it. Usually, that is a good thing, but it is now not even being recognized.

I have tried redownloading files, I have searched the entire website (WDC Support) and have gotten nowhere.


  1. I was going through my installed drivers and stuff and I came across something odd. In my Disc Drivers, I have a WB5000AAKS. It seems to be a WDC product. It has 500 Gb space and I guess that is what I have been using for storage. It is 93% full.

  2. My PC is old (not going to lie). I don’t know too much about it but from what I have read it is a PowerSpec product. (PowerSpec B637) PowerSpec B637 Specs Here.

Take it to Best Buy (tell them name of person who bought it so they know it came from BB and they can find the purchase on their system), Tell them what happened and that you followed WD’s “bad advice” to format it (really stupid advice).

ASK TO RETURN/EXCHANGE IT FOR A NEW ONE IN BOX. Hopefully they will do this for you. If not, get on phone to WD support and demand to exchange for a new one, NOT a refurb,

Once you have a new one, install on PC it first worked on (win 10). Once you have determined it works, then install it on Win 7. If you have issues call WD support and find out if it is a driver issue on PC, and under no circumstance do not reformat again or do anything to drive to screw it up. It just might be an incompatibly issue with Win 7.

1 Like

Did you already exchange it at Best Buy?