My Passport SSD only showing up as USB2.1

My SSD used to connect find as USB 3 using the USBC to USB converter that came with it. However I have been forced to upgrade my mac and now when I plug the device into my new macbook pro the device only shows up as USB 2.1.

I’ve also tried under bootcamp and while it should it is super speed and superspeed plus compatible (using USBTreeView) it still only connects as a USB 2.1

I’ve tried a PRAM and SMC reset as well as updating my mac to the latest version and still it shows up under both windows and mac as USB2.1

I’ve also tried it on another windows machine and again it showed up as USB 2.1

Has anyone any idea whats going on? This is very disappointing.

Interestingly I have a My Passport 4TB which If i plug in via a usb-c to usb hub shows up as a USB 3 device and works perfectly at high speed. Has anyone got any idea whats going on with the SSD?


No ideas?

Could it be a problem with the cable? I’ve tried it with the Mac’s charger cable as well … and still only get 2.1 and I would’ve thought that would be able to cope. Any thoughts?