My passport problem


i have a 1tb my passport essential se. just the other day when i restarted my computer, it didn’t recognize my hd anymore. so i unplugged it and plugged it back in and then it worked. then i restarted my computer again, and the same thing happened. for some reason it no longer recognizes the drive until i unplug it and then plug it in again. also, the drive seems to be acting a little strange. when i first start my computer  it feels like its spooling up to max speed even though the little light on it does not come on. it stays like that for about a minute, then stops. after the computer is booted up and i unplug it and plug it in again (so that i can use it) it does the same thing, though the light comes on and it’s recognized now. i don’t believe that it did that before. and another strange thing is that i can no longer “eject” the drive using western digital’s smartware or the windows ‘safely remove hardware’. it says that it is being accessed by something, but i’m not accessing it myself at all. i haven’t installed any new applications recently, so i’m not really sure what’s going on. i downloaded and ran western digital’s diagnostic utility and the tests said the drive passed. i tried uninstalling and reinstalling smartware but that didn’t work either. i use the drive solely to hold all my digital media for dlna streaming purposes. it’s very annoying now since my streaming software boots up before the drive is recognized, it doesn’t include any of the content on my drive in it’s streaming library. any ideas? seems maybe more like a problem with windows and not the drive itself. i emailed wd support, but it doesn’t seem as if they have any clue. it’s under warranty and i could get a new one, but i’m not ready to blame it on the drive yet. i wish i had another one to test to see if it is my computer or the drive itself. i’m just stumped. hope someone here has some experience with this. thanks in advance!

Me too having the same problem. Any one here suggest a solution.