WD My Passport Problems

Recently (as in about 4-5 days ago I was using a My Passport 1T external hard drive and I started to notice some problems. The problem I noticed was the media (videos in particular) I had was lagging somewhat after I clicked the video. I also noticed the computer took some time to view what was on the drive. Also when I try to transfer stuff it seems to take a little bit to load what is in the folder. 

I have attempted to defragmenter it, though I cancel it because it never gets past the 3% mark on the consolidating stage. I updated the Firmware and then I tried having the on board program in windows check the hard drive. I did not have it try to recover bad sectors, but I did scan it for problems. It didn’t say anything was wrong with it. I did a full disk scan scan within the WD Program to see if there was something wrong. The Program did say something was wrong, but did not tell me what it was or how to fix it. 

So what I am saying here is that I need some help/advice on how to fix this because I am running out of ideas on how to resolve the problem.

Hi Reggie, just to be sure use DLG to run a test, if the test completes successfully you might need to backup all of the files and format the passport. If the test fails contact support to check the warranty to see if you can replace it.

Well now I tried this solution and well I had to result in me formatting the drive with that program. But there is another little problem that is popped up. My computer can detect the My Passport Hard drive, but is not showing up in the computer section as a viable hard drive. Any help would be appreciated. 

If you selected the option to write zeros to the passport, you need to format it.

And i have done that by chooseing the quick erase. Waited  a day for it to complete. Now it is just not accesible to my computer even though it has been detected. I have tried removing it and reinstalling it to the computer itself through the “divices and printer” section, but that does not have any effect on it. I am trying the troubleshoot it now, but it hasent come up with anything. I also tried the SES program to see if it would do anything to it, but nothing ended up happening. 

I might try to do a full erase in the WD program after i cheak it for bad sectors again. I appreciate the help, and if you have anymore suggestions on what to do. I will definitly give it a try. 

Follow the steps for the link bellow and let me know if it goes. If you still have the same problem you might need to contact tech support to replace the passport.


It ended up working. Thanks alot.