My Passport Eessential SE 1 TB Does not work

Is there anyone out there they knows a little something about my little problem.

I have a My Passport Essential SE 1 TB hard drive, got it about a month ago. All of a sudden it stopped working. I get a flashing white light, I can feel the vibration of it when held, and my pc is just going stupid over it. 

I have been reading as many threads as I can to fix my problem, but either they are never the same problem, or I am unable to preform the tasks in which they mention due to different OS or different product.

I have tried using computer management, but they thing keeps on going nuts over the HD, constant (Not Responding) and taking 5 or more minutes to have the little task bar pop up when right clicked. “Devices and printers” is the same way, and My Computer takes over 10 min to reconize and then the same will happen.

I am currently in Afghanastan so the data recover company thing is a no go, and the mail in warranty might be my only option if nothing can be learned from here. This has almost all my personal stuff on it, and I don’t want to lose it. But I did get fed up last night and tried to reformat it, just wanting a working HD, but it took over an hour for the PC to tell me, could not forrmat.

Thank you for any help you can pass on.


Have you tried a different USB cable, USB ports and on a different PC?


Yes sir, I have tried another cable, another port and another PC, tho I did get different responces from the other computers.

Guy 1 said his pc did not reconize the drive, with 2 different cables

guy 2 said it made his pc act wierd and he was unable to call home with his laptop while the hard drive was connected…

I have noticed that my pc has been acting weird while I have been digging around. My pc has had trouble restarting with the HD hooked up… Could it have a virus?