My Passport not recognised by XP-Pro SP-3 -- IS in BIOS drive table

I have two Passports - bought togther at the same time.  Initially both were recognized by XP on my PC and by Win-7 on a laptop.

I defragmented one of the Passports and it is no longer recognized by XP on the PC. When it is plugged in there is the usual sound, and it appears in the “Safely remove device” dialogue. If it is plugged in prior to cold booting the PC, and the BIOS is examined, it appears correctly in the Drive Boot Priority table. In short, it is recognized by the mother board BIOS but this information is no longer transferred to the drive table of the XP operating system. This drive still works perfectly under Win-7 on the laptop.

The second drive - which was not defregmented - still operates properly on both XP and Win-7.

I have examined the MBR and GUID table on both Passports - the one that does work and the one that does not - and I can’t find any significant differences other than the disk serial numbers; which I expect to differ. But my software does not have the ability to examine the USB interface code, and I suspect the problem is there.

At the direction of WD support I have tried every approach they recommended, but the problem is not fixed. It seems that this problem appears repeatedly on this forum, and it seems that WD has never actually addressed it in their production process. Perhaps it is time they tried to reproduce the problem, find out what is causing it, and come up with a solution. Obviously some entry in their software is at fault, but unless they tell us what it is we can’t fix it.


Take a look at these links. Hope they can help with your issue.

WD external drive is not assigned a drive letter by Windows and data on the drive is inaccessible 

How to change the drive letter assignment in Windows 8, 7, Vista, XP or 2000