WD external drive not recognized on Windows 7 (or 8)

I have spent *hours* scouring the web on this topic. Even broke down and sent a message to WD support. No answers anywhere.

I have a My Passport exernal HDD.  I realize Passports are sold as Mac drives but I was assured reformatting in a NTFS system would solve that problem. And it did. The drive worked a few weeks then quit. Not in device manager or disk manager or anywhere. 

Here are some of the things I’ve tried so far (You may notice that I am getting more and more desparate)

  • Switched USB cables

  • Tried drive on other computers - Windows 8 (No joy) and Windows XP (Mom said she had no trouble with it on XP).

  • Installed, unstalled, ran in XP compatibility mood, rebooted, plugged in drive, installed driver, then tried installing driver before plugging in drive (catch my drift?)

  • Updated ALL drivers on the Win 7 machine

  • Tried to update firmware (quite impossible of course - wish I’d thought to ask Mom to do it on her XP machine

  • Put my left foot, took my left foot out, did the hokey-pokey (sorry to non-native English speakers that don’t catch the allusion

  • Tried running it through USB hub (used to be no problem), then tried plugging it directly in.

  • Investigated with programs that should have recognized a Mac file system

  • Removed my Windows account password (not sure what that was supposed to do, but I found it on some website or another)

  • I’m sure there are many other things I’ve tried but all to no avail

Very rarely, the computer will recognize the drive for a very brief period. On these occasions I am prompted to format the drive.

I really hope someone can help. Important stuff on the drive and I’ll also need it to transfer files to the new Win 8.1 PC.


Well, this is even more interesting. Mom’s computer does not run XP. It’s a Win 7 machine as well.

Try downloading and burning a Linux Live disk and try booting from that. Sometimes it will give you access to a problem drive. Since it isn’t showing in Device or Disk Manager I suspect a problem with the drive.


Thanks for the advice. I’ll try that.

I don’t think it’s the drive. It works perfectly fine on some machines.