My Passport is not detected

I was trying to unlock my WD My Passport. The unlock.exe was running okay. But, the hard drive didn’t show up in ‘My Computer’. I was using it last night when it suddenly stopped. I thought the disk need to rest a while so I disconnected it. After an hour, I tried again. It’s still the same. Only the unlock.exe showed up. This is my 2nd external from WD. I sent the first one to warranty because it can’t be detected.


Please try some basic troubleshooting.

1- Disconnect the drive from the computer and restart the computer.

2- Please try connecting the drive to the back USB port of a desktop PC for testing purposes (directly to the PC, not through a USB hub). Try using a different USB cable if possible.

3- Make sure you hear the connection sound windows makes when recognizes a USB device.

4- Go to "Disk Management” to verify if the drive shows up there. 

If the drive shows up in disk management but it is not seen on Computer, then it means the partition is corrupted and you will have to format it in order to use it again. Please note that formatting the drive will delete all data stored on it.

May better way. i not loss data

1 Like

That is an excellent suggestion, nisit! Thanks for sharing your knowledge!