My Passport for Mac - Yosemite

My Passport for Mac will not work properly with Yosemite.

It shows up on the Desktop but then keeps clicking and stopping, when you try and copy data to it  - it starts very slowly and eventually stops. 

If I run Disk Utility on it I get the message that the Disk needs repairing, you repair it and it makes no difference.

I have the lastest firmware on the device plus when I connect it to my Mac BookPro running Mavericks it works absolutely fine, no problems at all so it must be a problem with Yosemite.

Can anyone help me with a solution?

Hello mousetarget, welcome to the Community. As a troubleshooting step, try connecting the Passport directly to the Mac, avoid using USB extension cables or USB hubs. You can also try connecting the Passport to another Mac to verify if the same problem happens. 

Many thanks.

When I connect it directly to the Yosemite Imac its even worse, rarely mounting even and then incredibly slow and then stops. I works fine on my Mavericks iMac - any ideas?

In that case the problem could be related to the Yosemite iMac. Some computers don’t offer the same power on all USB ports, try connecting the Passport on different USB ports to see if you get better results. 

I have the same issue. I’m using the same iMac, and the only difference is that after the Yosemite upgrade the WD drive started having issues. It’s therefore an incompatability issue with Yosemite??

Its definately a problem with Yosemite - it works absolutley fine on my Mac Book Pro Mavericks.

It could be the drivers on the unit itself? - if so is it easy to remove these and use something else? It must be a software conflict?

Having a similar issue. So I have a MacBook Pro (Retina, 13-inch, Late 2013) 2.4 GHz Intel Core i5 8 GB 1600 MHz DDR3 running OSX Yosemite 10.10.1 I have purchased this HD (hard drive) back in July and have not had any issue until recently. It is connected through USB. For some reason My Passport Ultra SOMETIMES is not recognized on my mac (about 95% it is not recognized). But rarely it does connect. It doesnt show up on my sidebar, or on disk utility.  I have tried attaching my phone, other devices and other HD’s to my macbook pro with no problem. They all connect successfully. I even take the My Passport Ultra and it connects onto other Macs and PC’s with NO problem at all. I am able to view everything add/remove items. But it wont connect on my Macbook Pro 95% of the time. But once it does connect for the 5% of the attempts to connect it works fine. If i go into standby its still connected, but if i unmount it or restart the computer, its lost again; it wont connect. Not sure what to do in this situation, I need everything on this HD and I know everything is still intact because I can use it on other computers. But I really need to make it work on this computer again. 

Hope this helps someone out there as I have solved this problem - my passport for mac would mount but would stop and start when copying (very slowly) - I just reset the SMC and it now works fine! Hope this helps people out there

Pardon my lack of knowledge - but the SMC? What is/how do we reset it?


No problem, SMC stands for the System Management Control - it controls electrical supply in the iMac as well as alot of other things - to reset it shut down your iMac, then remove disconnect anything else to the iMac - USB leads, mouse, printers etc. Remove the power cable from the back of the Imac.

Then wait for 15 seconds - then plug the power lead back into the iMac and attach all other leads again and start up. And thats it - hope this helps as this problem drove me crazy with the WD drive for over a week!

Just marking in case I actually get the Yosemite update…

I’ve the same problem.

Sometimes my ultra is recognized, but in the most cases it can’t be mounted.

In mavericks it was working fine… :frowning:

Do you know the solution?


I have been having the same problems as had been listed and did as you suggested with the SMC.  However, it still will not back up.  The Passport light blinks for a while, then goes steady.  Looking at the passport control box on my computer, the circle goes around for quite a while and then a message appears at the top of my computer saying, backup failed.  I am at a loss.  I replaced my old passport with a brand new one as this was my issue with the old one (about 3 years old).  However, with the same message coming up on this one, I really am perplexed.  The My Passport I am using now is for Mac, 1T backup capacity and right now it is not backing up anything.  If possible, can you give some advice.  I am running Yosemite on my iMac.  Thanks, RCDief

Hi RCDief

It sounds like you may be having a different problem to the one I had - mine was more about not the right amount of power getting to the Passport, hence resetting the SMC did help - nevertheless - you could try simply a different USB Port on your mac, or even the USB port on your keyboard if you have a wired one.

It might be worth just resetting the SMC one more time, it doesn’t take long and could work this time. Othe than that, make sure you have the latest firmware update for the Passport.

Wish I could be more help as it is very frustrating when it doesn’t work. You could also post on the Apple Support Communities forum.

Kind Regards


1 Like

Have new WD My Passport Air. Cannot get it to work with new MacBook Air and Yosemite. I have downloaded WD Drive Manager Installer, WD Drive Utilities & Security, WD Firmware Updater, WD Drive Manager 3.1.0 and Firmware Update The drive shows up as an icon on the desktop but clicking on it just brings up the contents - MY–Passsport_Apps– Clicking on this just re-installs already installed software. There’s no point of entry - no dialog boxes or any way for me to get it to function. It seems a nice product but I may have to return it. It seems like if they’re gonna’ call it “Air” - it oughta’ work with one! Any help would be appreciated.

Brand New, out of the package, 2 TB My Passport Ultra not mounting on Yosemite iOS 10.10.2 on mid-2009 MacBook Pro. I have a 1TB My Passport which works just fine. The USB 3.0 cable says that it’s compatible with USB 2.0 so I’m not sure if that’s the issue. I plug the 2 TB My Passport Ultra directly into the MacBook Pro and it’s receiving power because the light comes on and I here the drive spinning but it’s not mounted or see in the finder NOR the disk utlity to format it. Again, my 1TB My Passport USB 2.0 works just fine, but I wanted to move all the files to the new 2TB and I can’t get it to mount in order to format it in the first place.

I’ve gone back and forth with someone from WD via email and it’s not going anywhere. He said I forgot the password and I tried explained it is new, out of the box, and it’s NEVER been seen or mounted, so how can I set anything or format anything? He wants to set up a screen share so he can have access to my laptop to fix it but I really don’t see how that’s going to help. I’ve deleted all the WD SmartWare because I never use any of that stuff. It just gets in the way and I find it annoying. Any ideas on how I can get it to mount so I can format it? WD needs to just start making drives formatting for Mac right out of the box. This is getting old.

Well, I bought a WD Passport for Mac last December 2013 and it worked fine with my old MBP with Snow Leopard and it still does. I have now bought a brand new MacBook Pro (two weeks old) with Yosemite already installed and guess what? My Passport won’t work with it. Occasionally - about 5% of the time I try it, it blinks and starts to work, then suddenly it stops working completely, and a message appears on my computer effectively chastising me, saying something like:- “you have not ejected this disk properly, please eject it properly in future”. So, every time I plug it into the new computer it is ejecting itself. Great….why would that be?

did you all find a solution? I just upgraded to yosemite and find my drive non functional a 1TB passport WD>

Now should I go back to mavericks to use it? 

did you find a solution? Have you tried it another mavericks? I just upgraded to yosemite and it was not functional. thinking of booting a ext hdd on lion and then trying it.

As I just posted in another thread…I hope this helps you all a little ……I have solved the problem - at least for my new MBP with Yosemite already installed. I noted that my new MBP has USB 3.0 port/cable and my old MBP with Snow Leopard (with which 2TB My Passport worked perfectly), has USB 2.0 ports. SO I bought a USB 2.0 hub and voila!! It now works perfectly every time on my new MBP with Yosemite. In fact it works better than it did with the old laptop. So, it may be worth you all trying a USB 2.0 hub…