My Passport for Mac not Working after Upgrade to El Capitan

I upgraded to El Capitan and now My Passport for Mac is not working. My MacBook Pro will recognized it for a few seconds and the the drive will eject itself.

It sounds like a lot of people are having this issue. Has anyone figured out why this is happening?

1 Like

Same problem with WD my passport (one year old) the light is blinking but the disk is not found


Same problem for me, only on USB 3

I have try on USB 2 and it works :wink: !

Do have a different cable of USB 2?

I use the same cable !
But an USB 2 cable works too !
For me i just change the usb port on my Windows10 ( i have just 1 port USB 3 ) and it works on other port

Strongly suggest that you call WD customer tech support for instructions. Even though I have not upgraded to EC yet, I did call to confirm compatibility.

Personally, I never upgrade until I confirm w/the 3rd party manufacturers their hardware will be compatible.

Same here, upgraded to El Capitan this morning and now My Passport for Mac not seen other then in Disk Utility.
Also looks like I cannot connect to my My Book Duo either!!!

Just had this reply from Apple

WD Passport for Mac is no longer working
Uninstall any WD software on your Mac.
If the WD will mount in Disk Utility, reformat (erase) it.
You may have to reformat the drive on a Windows machine if it won’t mount in Disk Utility, though.
Some WD drives have had firmware in them in the past that was incompatible with Macs. If that is the situation (again), then a solution is to remove the drive from the enclosure and put it in another non-WD enclosure.
The best thing to do with WD drives is not to buy them in the first place. They come with software on the drive that is unnecessary and incompatible with Macs, software that they want you to install on your Mac that is unnecessary and incompatible with Macs, and sometimes the incompatible (and unnecessary) firmware issue.


I’m actually having the same problem with a My Passport Ultra that I just purchased. It’s not a formatted for Mac. When I went to format it for Mac, my MacBook Pro recognizes the Ultra for a few seconds and disconnects itself. I have not had any of these problems before upgrading to El Capitan…

Hi All, I bought a WD My Passport Ultra. I was running on pre-El Capitan, I wanted to use Time Machine back up to use on a new mac…I formatted the Drive (using WD Software, which I had to upgrade) before I upgraded to El Capitan, to make sure the it worked. Worked like a charm. I upgraded to El Capitan and the Drive would not work anymore, it would not last over a minute before disconnecting. I visited many forums, even went out to get a USB Port as some people advised this worked. Not at all. The solution, is to get rid of the WD software once. I used the uninstaller for the software and restarted for the upteenth time today it finally worked. I formatted before the upgrade, but was also able to reformat once I upgraded ( I believed I had done something wrong, so redid it). As we speak 6GB out of 320GB backed up, without failing, Good Luck.

I bought a My Passport Ultra that required formatting for mac. I’d already updated to El Capitan. I couldn’t erase or partition with Disk Utility. Then read that if you use Time Machine and select the My Passport as the drive it will ask to erase. It worked. Then went back to Disk Utility and was able to partition and it works fine now

HI there,

Just asking. Did you find out any solutions for that?


Hi there,

Did you managed to get the HD working for El capitan by any chance?

Please let me know.

Thanks in advnace!