Changed to El Capitan and not my passport 1 TB will not mount

I recently upgraded to El capitan. Prior to this my passport drive worked fine. Now it will not mount at all
No way to repair it in disk utility because it doesn’t see it. I have a ton of information on my new book in there and need to get to it., FAST. How to I get my mac to see this drive. Recently updated software as per your updater.
Please advise seriously desperate!!!

Kindly go through - El Capitan & passport ultra
You can also try reinstalling the WD Drive Software

See if any of these tips make a differences

I can confirm that My Passport is not compatible with any OS after Mountain Lion. I have a Macbook Pro and purchased a My Passport for mac. It was working great until I upgraded to El Capitan. I’ve read through every forum here and on the Apple site, but was never successful in getting it working. I just spend 1 hour and 15 min on the phone with WD support and they told me 100% that the My Passport for Mac IS NOT COMPATIBLE with any iOS after Mountain Lion. I was told there were a couple of things we could do to perhaps reformat the drive for the mac, which meant wiping the entire disk, but after an hour and 14 min on the phone, nothing worked. I even had to pull an old windows laptop out of the closet, dust it off, and use it in the process, but nothing worked. So at the end of it all, all my data was wiped from the drive (not sure I will be able to recover it all…) and the drive was diagnosed as corrupt and unusable… SO, The My Passport will not work with El Capitan or Sierra or any OS after Mountain Lion.

Well really sorry for your problem. But I have a Macpro that I changed to El Capitan and after one phone
call to WD, one little fix and BOOM, everything works perfectly. I have had no problems backing up .
Maybe there were underlying issues with your machine, but honestly, I have had NO problems and continue
to use My Passport and Elcaptitan happily

1 Like