My Passport for Mac: light blinking but nothing happening!

I’m fairly upset. I’ve been using the My Passport for Mac for about two years with no problems. I have not updated anything on my macbook. Nothing has changed since my last backup, which was ten days ago. I have a Macbook Pro, OS 10.9.5.

Now when I plug in my external hard drive, the light just blinks nonstop. Nothing mounts. No error message, no nothing. I tried the other USB port on my Macbook, but that didn’t help. I restarted my Macbook and still no luck.

Did it just die?? Do I simply have to buy a new external hard drive? (If so, it won’t be another one of these, and any suggestions are most welcome!) I don’t see anything on this forum about this problem, so I’m thinking it’s not a simple problem. If anyone has any idea what could have happened, and whether anything can be done, please let me know. I’m pretty disappointed that something like this could happen out of the blue.


It is possible the partition is corrupted and you will need to format the drive in order to use it again.

You can also try replacing the USB cable just as a troubleshooting step.

BEFORE you reformat the drive, have a look at your User’s Manual (UM) and try a Reset. I am able to rest my MyBookLive (MBL) while the unit is powered up without losing any date. This has saved my hide on several occasions. It is likely that WD incorporated the same features into your drive. Have a look at your manual before you do the reset. NOTE: Factory Restore ≠ Reset, and on my MBL a Factory Reset reformats the drive, hence should be avoided, except for desperate measures to saved the drive. GOOD LUCK !

I’m having the same issue. When I reconnected my passport to my Mac it was not mounting but the light is on. I tried ejecting but it says it wasn’t ejected properly. I also tried running a diagnostic using the disk utility but the result indicated that my passport appears to be okay. My passport is also directly connected to one of my Mac’s port.

Please help!

1 Like

I am having the same issue, I’ve had this hard drive since 2017, its connected directly to my iMac port and it all of a sudden stopped working, the light blinks but the drive doesn’t show up anywhere on my computer to run any kind of diagnostic.

Try this:

  1. Go to Finder
  2. Select from the Go menu the option Computer
  3. You will see the MyPassport option

For some reason its not showing automatically but its still there