My passport external drive problem (with multiple macs)

i have a year old usb 3.0 my passport external drive. i haven’t used it in a few weeks. it had been fine. i had been in the process of transferring everything off of it but hadn’t finished and tried to plug it in to resume the process tonight but it was not mounting on either of my two macs (a macbook pro and an imac, both running os 10.9.2). the light on the drive lit up and the drive was spinning strongly (very quietly…no death clicking or anything) but wasn’t mounting on either computer. didn’t see it in disk utility either. in the weeks between use i had taken it on a trip but to my knowledge it hadn’t been banged or jostled in any hard way, if at all. i can’t remember if the computers had been running an earlier os 10.9 last i used it. but i guess my question is…is there anything i can do outside taking it to some sort of data recovery service? maybe i’m fooling myself but i feel maybe the data at least is recoverable as the guts seem to be running normally. i suspect maybe the problem is in the actual connecter slot to the usb cable. it’s not the cable. tried three. but the connecter slot seems maybe a little loose? maybe it was always this way. and maybe this is a firmware or whatever issue with the new OS? the drive powered up so obviously the cable connection was doing something. thanks for any thoughts!


I recommend you contact support to see if they can help.

General Phone Support

i took the drive to a data recovery place for a free diagnostic. they said they think the drive is fine physically and the issue is with the firmware and that they couldn’t help with this. i spoke to WD and they suggested i try plugging the drive into a PC and not a mac. i would imagine the data recovery place tried that although maybe they didn’t. i have no idea how to solve a firmware issue. the WD person on the phone wasn’t very helpful in this regard. i don’t even know what i’m asking at the moment. i guess if anyone has had success on PC if it wasn’t working a mac. and if anyone has solved a firmware issue on a mac. and if anyone had any other suggestions. the drive continues to spin quietly with the light on (not blinking). the data recovery place essentially suggested just hold onto the drive since it seems like it should work and maybe in the future some update to mac/WD firmware (i’m unclear on which) will allow it to communicate again.