My Passport Essential 500GB Not Detected By Laptop/ Windows 7


I wanted to see if I can get some help with this external drive.

My Passport Essential 500GB # WDBAAA5000ABK-00

I was using this on 2 different laptops with Windows 7 OS’s But it was almost full so I copied all files to a larger drive and formatted it and now neither laptop will detect it but a third laptop with Windows 8.1 will detect it.

The laptop I am wanting to use this drive with is:

Dell Inspiron 1721 with Windows 7 Home Premium 32 Bit

So I am thinking it is not the USB cable but I tried a different cable and no luck

Does not appear in “Computer”

Tried multiple USB Ports

Light is on and I can hear drive spinning.

Have run Windows Updates

Should not need driver as Window 7 should have this?

Is not listed in Device Manager under Disk Drives or USB Controllers nor is drive listed in Disk Management.

In Device Manager I tried :Scan for hardware changes" under action tab and “Show hidden devices” under View tab. No Good.

Any suggestions would be most appreciated!


Update: Does appear in Device Manager on Windows 8.1 laptop but not in Computer or Disk Management.

gregmy123,  I am having the exact same problem… I updated my software today, and now my computer will not detect my passport. The light is on, and I can hear the drive spinning as well, I have windows 8.1, and windows 7, I tried it on both computers, and no detection at all.  But 10 minutes before I did the update, it worked on both computers…  I am really upset, I need the files on this passport, I did not copy these files before I updated the software… I have tried every kind of fix I found on the internet, nothing worked… I would also appreciate any suggestions!!


I have the same problem. Let me know when some suggestion on fixing this comes up. Like all of us, I want to access my files. 




Have also tried downloading  and installing SES driver ( from But this did not help.

Tech Support offered to send me a USB booster cable that takes output from 2 USB to one increase power to Hard Drive.

Will see if this works!

Contact WD Tech Support and ask for a USB Booster Cable that takes power from 2 USB ports and boosts power to HD. They are sending me one and I am waiting to try and will let you know but you might get one. They will want to opena ticket but should send you one.

Also, Did you try to install SES driver from WD website under support/downloads and then plug in HD?

Good Luck!