My Passport 4TB SMART Attributes Missing


I brough a WD My Passport 4TB drive in Januray 2017 (new version) - WDBYFT0040BBK-WESN.

I have recently checked the SMART reporting (through various applications including the Windows WD Data Lifeguard Diagnostics software. The drive only has 4 SMART attributes and it is only reporting:

  • Read Error Rate
  • Spin-Up Time
  • Reallocated Sector Count
  • Temperature


All other drives I have (WD and Seagate) have may more SMART attributes including Power on Hours and count etc.

I’ve checked the firmware which is the latest and re-intsalled the firmware and there is no change.

I’ve tried raising a WD Support Case, but not getting very far, other than being told to run a full disk check with the WD Data Lifeguard software. I can’t get confirmation if this is how the drive should work or is an error.

I can’t find much on the internet or on here.

Does anyone else have the same issue and what have you done or any recommendations?

Many thanks

I am not aware of the list of supported SMART attributes for this particular unit, and I have an older WD My Passport, so I am unable to confirm if this is the unit’s default behavior.

Have you tried running tests as an administrator or using a USB 2.0 cable to force legacy compatibility mode?

Thanks for your reply and advice.

An older 2TB My Passport shows approx 15 SMART attributes. I haven’t had an opportunity to run a full test as a 4TB drive will take some time, hopefully I will get a chance over the weekend.

Unfortunately due to the connection I can only use the included USB 3.0 cable, I have tried it in a USB 3.0 and USB 2.0 port and no change.

Micro USB 2.0 cables will fit the flat half of the Micro USB 3.0 connector (Leaving the square half empty). It is not proprietary,

Thanks again for the reply!

I found a cable able to try the USB 2.0 cable theory. Unfortunately this made no difference and only 4 SMART attributes are showing.

I’ve also completed the Full Extended Test of the drive through WD Data Lifecguard Tool for Windows and the drive passed with no errors (not really expecting any).

However the SMART attributes are still only showing the same 4.

i have the same problem with my MyPassport 4TB!
Why is there still no solution for this issue? After months…how can that be?

Unfortunately as long as the drive checks show no errors it’s working as designed.

It took me a long time going back and forth with WD Support to get complete confirmation.

They decided to reduce the amount of SMART data as it was confusing end users and creating unnecessary support tickets which were being raised when there was no issue.

I don’t know which WD products are affected by this poor design decision. I can only recommend contacting support and getting confirmation before any future purchase.