My laptop does not recognize my wd passport


I have a My passport essential usb2.0.  I have backed up all my data successful. I have then had to do a complete re-fresh of my laptop as it was so slow. Refresh went ok. Plugged in the Passport and drivers were installed successfully, however it didn’t auto start.

Tried looking in computer and it doesn’t recognize MY passport. I have used disk management and it shows as disk 1 unknown 298.06gb unreadable. However id I right click then properties and then general tab it says this device is working properly. So looks to me as if my laptop cannot recognize the external drive.

I am tearing my hair out as am worried I have lost all my files and photos.  My computer is a dell vostro 1500, running windows Vista

Any idea how I can get this fixed

many thanks


A bit more info.  I have since downloaded windows service pack 1 and now when I use disk management, it now prompts me to initialide the disk where the WD passport is.

I have right clicked and tried to initialize. It tells me to use the following partition style and gives me 2 options. It recommends MBR (Master Boot Record) and option 2 is GPT (GUID Partition Table). I tried the MBR and then get a warning message telling me “The media is write protected”.

Any ideas what I do from here??