Unknown Device / USB Device not Recognized


#1

Hi folks,

 I’ve got my Passport (500gb) a few days ago.

The initial installation and backups using SmartWare was smooth without any problems.

Out of curiosity…, I right clicked on the drive in explorer and did a ‘quick format’ using NTFS format.

I was still able to ‘see’ my drive using WD SmartWare after the reformat and  I intended to redo my backup again…

alas!! My Passport disappeared from the explorer and endless attempts to unplug and plugging into the USB port ended with ‘USB Device not recognized’.

I tried googling for answers and tried using my XP installation without any success.

Is there anyone who can help please?

Some notes,

I’m running Windows XP (SP3).

My passport LED is currently blinking continuously.

 I’ve tried plugging once into my friend’s PC running Vista and I was able to see ‘My Passport’. I’ve not tried to reformat yet. (Will try tomorrow).

There should be no problems with the power supply since I was able to use it on my PC the first time.

Thanks!!


#2

Hi ziczach,

It seems like it could be a corrupted partition. Try going into the disk management and check how the drive shows up, and try to format it from there.

Here is how you can format it in the disk management.

Link to format in disk management


#3

Hi MrProbinsky,

Thanks for your reply… I’ve tried that but the disk doesn’t show up.

I’ve just tried in my office’s Vista and it’s also facing the same problem…

Seems that the disk’s a goner now…

I’m going back to the retailer for a replacement.

Really disappointed with WD.

This’s my 1st  harddisk that has given me any problems…

My old 2.5" Samsung  has dropped a couple of times and it didn’t give me any problems… and now, this junk didn’t even last me a week without me doing anything!  :frowning: sad…


#4

The drive was not recognized and I tried to update the firmware but it is impossible because my laptpo cannot see the HD passport 640 GB that I just bought on Bestbuy.


#5

You may try a usb booster cable or a cable with two connectors so it can draw more juice for the drive.


#6

Hi,

    I had the same problem with a 250gig version I have for about 2 years. I could hear the drive spinning but usb device not recognized. I think I blew it by not stopping the usb device when I unpluged it. I bought a sata usb caddy from ebay for 5 £ and swapped the drive out and was able to get my data back. The usb interface for the drive was blow. If you can hear the drive spinning and its not making any “funny” sounds it might be just a blow usb card