My cloud was working ... but now

Got everything set up and even moved some pictures over from my laptop and tablet. Now it won’t let me access it using the my clould desktop app.

First it gives me a security alert “This page requires a secure connection which includes server authentication. The Certificate issuer for this stie is untrusted or unknown. Do you wish to proceed?”

 then I click yes and it gives me a security alert that says “A secure connection with theis site cannot be verified. Would you still like to proceed? The certificate you are viewing does not match the name of the site you are trying to view.”

 If I click yes again, then it gives me this security alert again and again until I say no “Revocation information for the security certificate for this site is not available. Do you want to proceed?”

 not sure what to do now.

I read a lot online about a java problem, but not sure if that is what this is.

Thanks in advance!

Have you tried to access the My Cloud from the website? If you encounter any Java security problems check the link below for more information.

Yes, I have tried the desktop application AND the website, neither works.

I have tried the suggestions at and it still doesn’t work.

What should I try next?

Thank you!

I unplugged and plugged it back in and now it connects again. Is this common?