Issue with Security Certificates on Windows PC using WD My Cloud.exe and


3m ago

I am away from home, and I have excellent and fast access using my iPad MyCloud app. 

However, on my laptop,  I cannot access my shares using the PC desktop or the web access.

Running Vista, Firefox, with latest Java and Firefox updates. 

After entering my password using Web Access, a security dialog pops up and the mesage is “Application Blocked” 

 “The application was blocked even though the host site of the file is included in the exceptions list…”

Using the desktop app, WD My Cloud.exe, I can connect successfully, and see my public folders, but I get security certificate warnings for each folder and file I try to access.

I have tried for hours to find a solution, installing the certificates and turning off firewall and anti virus.  No success.

Same problem.  Sent all the error info to WD got a shrug off use or software (which doesn’t provide full utilization of the my book drive).  Problem is the certificates, has been for months, at first it was just with IE latest update to Java blocks with chrome and everything else.

Would you believe WD had the Audacity to tell me to check my Java version when they are getting this same complaint from everyone.

Love the drive HATE what WD is doing (or not doing)


I called WD MyCloud Support at 1 800 275 4932.

The rep said there is a known incompatibility with the Java 7 Update 51.  He advised that I uninstall 7.51, and download and install Java 7 update 45.  I did this and also updated Vista to the latest service pack.

Now WD My Cloud.exe can open my shared folders, but it is really slow to open my music files (.wav).  A 37 Mb file  takes 2’30" to open.

I an connect through the web app, after bypassing a couple of security warning dialogues from Java.  Again the download time is very slow.

NOTE: on my iPad app, the download is almost instantanious.

Yes removing the latest java and going back to release 45 has also worked for me. Clearly the latest java is incompatible with WD software.

Mind you it was warning on the last release that this application would be blocked after the update, and “please contact the software supplier to get a new certificate” so its not too surprising.

I experienced the same problem on my desktop this weekend after installing software for MyBookLive personal cloud support. Firefox had no security certificates! It was so bad I switched to Google Chrome just so I could get access to things on the web.  I will try dropping the Java version back tonight and see what happens. 

I got a lot of music and photos transferred and was able to backup my wife’s laptop.  It’s a good product concept and I will probably buy a second MyBookLive to backup the cloud content once things settle out.

It’s a shame that WD doesn’t recognize that they have a serious issue here.

Same problem with desktop/laptop windows 7. All is wright with iPad.