My cloud is still not working. Is it fixed?

too, EU

Mine is still not working!!!

Mine WD My Cloud Home is still not working too…

Still not working after 5 days!! None of the recommended actions has worked out. I am trying to escalate the issue and to contact Customer Service, but rather impossible to get an answer. It is really disappointing.

1 Like

If you are located in the US, you should all have been updated successfully by now if you had unplugged power to the MCH, wait 5 to 10 seconds and plugging back power and waited 15 minutes. If you are located outside the US, your best bet is still to wait until the local servers are updated in your country. If you are in Iran or China, it is possible that you may not get an update.

Your best bet in those countries without an updated local server may be to

  1. Wait for an update
  2. Use a VPN service with US servers and try to update that way*
  3. Mail your unit to the US and have someone update it for you*
  4. Consider using a different NAS or cloud storage since WD servers are so unpredictable in your country.

*(There is no indication that the MCH has its localization locked or is region locked, so that the firmware used is probably uniform throughout the world.)

This security certificate problem which necessitated a force update originated from a service provided by Let’s Encrypt’s root certificate which expired globally on Sep. 30, 21. WDC had to force a firmware update on Fri, Oct.1, 21 and most users in the US were able to update on that day, however many users around the world could not because their local servers could not be updated. What you are looking for is the WD My Cloud Home OS4 Android OTA update which looked like this in the debug_logs:


Any advice for US users who are still offline? I’m in Florida and the MCH was perfectly fine before October 1st. I have received no response to my support tickets and chat was no help either.

1 Like

So I found the OTA update in my debug logs but mine looks like this:

[DEBUG][install_a.cpp:main():853]package file path: /tmp/otaclient/fwupdate/install.img

Firmware update called on: Fri Oct 1 14:31:21 2021



[INFO][install_a.cpp:main():918]Reading boot config.
[INFO][install_a.cpp:wd_read_boot_config():325][INFO] bstate = 0, bna= 0, nbr = F


[INFO][src/rtk_tar.cpp:parse_tar():117]@parse_tar /tmp/otaclient/fwupdate/install.img 35

[INFO][src/rtk_tar.cpp:parse_tar():137]tarfile_path:/tmp/otaclient/fwupdate/install.img, tarfile_size: 650997760 Bytes (635740 KB)

I have no clue what any of this means, or if it helps identify any issues? If you can provide any info I’d really appreciate it. Support still has not gotten back to me. I’m sure they’re swamped but it’s been 5 days and I don’t know who else to reach out to?

You would need to scroll down to line 1058 and 1171 or search for ‘success’ and if the flash was successful, you should have access to the MCH. Your inability to reach your MCH may be due to other network problem and I would troubleshoot it by swapping cables and unplugging power to the MCH, wait 5 to 10 seconds and plugging back power. Sometimes users would also reset or upgrade their router or change settings and lose access to the MCH.

Well upon further inspection looking for the lines I found this:

[INFO][install_a.cpp:main():1048]DHC install_a (JH version), date:Jan 4 2021, time:13:28:40 REV:969406M



This is bad right? I’ve swapped cables, unplugged power to the MCH and waited 30 seconds or more to plug it back in. I haven’t reset anything or changed the router. I’ve also not messed with any settings. Thank you so much for your help so far. Would you happen to have any other ideas or suggestions?

I finally received a response from support after they reviewed my debug files. Apparently, there are disk errors on my drive and it will need to be replaced. They say there are only two companies who are able to recover data from a My Cloud Home device and I was given a 10% off WD coupon code. Since my device is under warranty I’m assuming it will be replaced but I have yet to confirm that.

These guys are corrupt just like the HDD that they stuck in the MCH. It is quite likely that if WDC had use a conventional magnetic recording (CMR) instead of a SMR (Shingled MR), the drive would not have failed under OS and NAS read and write condition in such a short time as in your case. This is why WDC settled a law suit and agreed compensation for those who bought a NAS (or alike) device having WD SMR drives.

You should read the kernel log from the and search for ‘ata-1’ and document a picture of what HDD you have in your MCH from the log. This way you can also make a claim against WDC for putting such a crappy drive in the MCH. You won’t get much money, but you may feel better. See this thread here:

I appreciate this advice and will most definitely look into it. The whole thing doesn’t seem right. And the fact that the device was working perfectly fine before October 1st seems too coincidental. I’m wondering how many other people are getting the disk error response from support and are now left forced to pay the only two companies, they say, that can recover data when it’s due to a loss that WD seems to have caused. It appears to be a scam ring if I’ve ever seen one.

Just finished the search through the debug logs and this is what I found: ATA-10: WDC WD40EFRX-68N32N0

Oops, that means you can’t file a claim. WD40EFRX is a CMR drive and supposed to be a better drive, but I thought they stopped using that around 2018 in the MCH. There is also the possibility that you have a SATA controller error, like another user recently who read the pstore log from his debug_logs.