My cloud is still not working. Is it fixed?

My cloud is still not working. Is it fixed?
I’m living in Republic of Korea

I am in Thailand and NO it is not yet fixed. This is abserd. I really need my files in the drive.


It is back up now. Restart will reset the unit.

I have restart the MyCloud device. It still is offline and inaccessible locally or through the Net

I am in the UK

And now its back online…

1 Like

mine is still not back … anyone else?


Its ok now (greece)

This was a global problem, I quote the recommendation from WD support that solved my problem.

We experienced an issue with our service that brought your My Cloud Home or ibi device offline. We understand that your data is important to you, and the content on your device is not at risk from this outage.

The issue has been addressed with an update that is now available. The update will install automatically within a few hours, or you may speed up the process by power cycling the unit once.

The My Cloud Home and ibi Team

Now, My WD home cloud works normally. The light is not blink as previous during issue.

Mine works now

still not working from my end.
i click WD discovery icon, i can see my device, click sign in, back to let’s find your device.
any suggestion?
or can I take out the hard disk from my cloud home and do the files transfer from SATA adapter?

I have the same problem. I cannot add the my cloud home via It always says I need to contact the admin, which is the user with which I’m logged in. ALso resetting the Device Owner with the button didn’t work. The device is always blinking slowly. Any suggestions highly welcome.

Mine is still offline. (GERMANY). I have sporadic connection to the Public files. But the rest cannot be seen. Over the mobile app I can see that my cloud has been found but cannot connect. Starting to get on my nerves as I require Dokuments that are stored

Mine is still offline. WD service is pathetic… 2 cloud discs with them and one was faulty and I lost all the data and they did not care and now with a home duo… My last purchase to WD

1 Like

My Home Cloud is not working (Spain) some days ago, and I’m very surprised that WD doesn’t update daily the problem status and when it will be fixed. It should be a high severity issue and should be solved in hours or very few days…

I have checked right now and it is working!

Same problem here (Canada) , still appear offline
And I still front light is totally dark.
This is clearly the last time I’m buying a WD backup device :frowning:

Having offline issues in the UK, cant login to the app or the site now, anyone else having this issue.

Mine is still not working!