My Book Studio Edition II - Drive not recognised using Firewire 800 but works ok using USB 2

I have just purchased a My Book Studio Edition II drive to use with my IMAC. When I plugged the drive in using the Firewire 800 cable the drive would not mount and was not recognized by my computer.

I tried swopping the cables for the one I use with my portable hard drive, and it still would not work.

I then tried using the USB 2 cable, and immediately the drive mounted.

I then tried updating the firmware for the hard drive but the Firewire 800 connection still does not work.

Has anyone got any ideas why USB2 works and Firewire 800 does not or have I just got a faulty unit?

PS. I am running Snow Leopard at the moment as I have not upgraded to Lion yet.

Verify your FIREWIRE drivers on the mac

Thank you for your response.

I am not sure this will help as I have already tested another external drive I have got and that works through the same firewire port and cable.

As mentioned in my original post, I  have tried swopping cables but no joy.

By the way, how do you verify your firewire drivers as you suggested? A general google search did not produce anything helpful.

Many thanks.

I don’t know much about Macs check out somethig called Turbo Driver here at WD I don’t know what it updated for sure.


for the firewire driver contact mac they will tell u how to update

but if u try a different drive and it work on firewire that it mean can be the firewire cable if the 2 drives has the same firewire try the other cable in the original drive to see if works if not them  try update firmware if not them u have a faulty firewire port

I had (maybe still do, but looks good now???) the same problem.  However I had to change the raid to Raid 1 mirrored.

Using the USB2 cable and WD’s Raid manager software.  Which I don’t think is the reason that it fixed it, but may have contributed.   But I read where someone on the internet that said Apple’s suggestion is to shut machine unplug everything all usb, firewire, power cable wait 15 sec (I waited longer played with my dog) and then plugged all back in and powered up and now it shows!!!, HOWEVER I had a 1TB Western Digital that now doesn’t mount, so did the new WD software cause a conflict with my older software?  FYI: Mac OS 10.6.8