My Book Studio II - Firewire 800 issue


#1

I had problems with my external drive today. It keep disconnecting (ejecting) when it starts to read the drive. It also disconnects after 10-20 seconds or so. I don’t know why. Also I have problems with starting up the drive. I press the power button and it won’t turn on. I have to unplug the back power cord, unplug the firewire cord, then replug first the power and then the firewire. It then turns on automatically but cannot load up or read, so nothing appears on my desktop. This is very frustrating as it sometimes works and other times it doesn’t. I know the actual physical drive is not the issue as all files load up properly and I am able to start copy things onto the drive, move files around, create new folders until ofcourse it ejects. However I don’t see the drive’s light being ejected (flashing like on sleep)…

I tried the USB port and that worked well. I backed everything up.

So I know there is some issue with something internally with the firewire ports and the AC.

Is there like a formal way of turning these drives on? I have three of these drives, 2 with 1TB and this one which I bought new as 2TB. They all sometimes have on and off problems, and I have tried every which way in order of unplugging ac, firewire and it sometimes works ok. This problem drive (2TB) seems to be in limbo. The lights are on but no ones home so to speak as nothing seems to react (based on the static light being on)…

Can someone please let me know a workaround so that I can use the Firewire port again. I have my whole iTunes library in this drive so using the workable USB port is way too slow to copy, stream/play etc.

Thanks, I hope I can get this fixed as I don’t have any money to get this fixed, or have any more room to back this drive up since all my other externals are full.

Thanks

KC


#2

 Can’t believe there are no responses from WD…


#3

Try swapping the firewire cables on the drive.  I see that you said you have problems with all of the drives intermitently?  This could be an issue with the FireWire bus.   I would advise giving support a call and looking into an advanced RMA  (if applicable for your area) and try a different drive.