My Book Pro Edition II firmware update failure

My Book Pro Edition II stop recognized after running this firmware update.

This update was downloaded from:


Unzipped, launched. After run - Firmware was updated successfully. Please reboot your comp. (or something like)


Windows says - New unknown USB device found

Blue ring on My Book light up continuously (No signs of life)


Disconnecting all cables from My Book, from comp and then reboot all system gave no results.

My Book configuration is:

1T - 2 x 500Gbt (RAID 0)

Disks model:

WD Caviar SE16
DATE: 06 FEB 2007


PWB 2060-701477-001
2061-701477-800 AB
XC 4D04 1FPX 1 0004310 7314

Main board:

PCBA 2061 701469

What to do? Any suggestions?

Hello Isramozart, have you tried connecting the My Book to another PC or using another USB cable? 

Shure! Not just change usb cable to another one, but trying firewire port too.
Also connected to iMac to see if disk recognized (even NTFS is not Mac file system).
Besides, I completely disassembled the box, pulled disks out and checked them individually using external sata to usb unit.
What else?
I tried to resset settings inside the disc using the button on the rear panel.