My Book Live not discoverable


So I’ve been using my My Book for over 1 year now with no problem connecting to it with my WD Live Hub. For some reason my Live Hub can see a new name “(Drive Name here)Twonkymedia” I select it and there is no media? If I connect to My Book with my Mac on the network I can see the drive no problem.

Also when I tried to run the My Book Live setup for Mac, the progam cannot find the My Book, error is “Your My Book Live drive was not found”.

I’ve also tried loggin in to …which I log in to fine, I then select My Book from “My WD Devices” it asks me for my password which I enter however it redirects me tohttp:// …what is going on???


Have you tried resetting the Live Hub? 

It’s recommended that after you do any changes on your network, reset all the devices so they can reestablish the connections.

Yeah tried resetting the Live Hub countless times. Will reset the My Book as well and see how I go.


I wish I had an answer, I have had a My Book Live 2TB connected to my AT&T Uverse 2wire router and used it wirelessly with my Macbook Pro with no problems for the past year. Somehow I am no longer able to connect to it. I am still running Snow Leopard (OSX 10.6.8),which I realize is a few OSX’s behind, but I’ve had no issues and am planning to upgrade my OSX in the next few weeks.  However, not be able to connect to my WD My Book Live has really screwed me. 

The only thing I can recall, that I did differently with my Mac was use the Sleep function for the first time just prior to losing the connection to My Book Live.  I have had my Macbook for about 3.5 yrs and had never put it to “Sleep.”  I either leave it on or just shut it down, but a friend of mine says she always uses the Sleep mode, so I thought I would try it.  This was about 10 days ago. I am not certain if that’s what caused my inability to connect to My Book Live, but that’s about the time I lost the connection.

I have spent the past week whenn not at work, pulling my hair out trying to get my Macbook to reconnect to My Book Live, but for some reason it’s not. All of the “normal” functions lights are illuminate on the My Book Live and I have reset it and my router numerous times.  I even directly connected the My Book Live to my Macbook via Ethernet twice. Although My Macbook Pro recognized the My Book Live with the direct ethernet connection, I couldn’t figure out how to access (or “mount”)  My Book Live.  I could see in Network Preferences that I had it connected correctly, but I saw no way to open it.  I have tried updating the WD smartware, quickview, and security sofware as well, but absolutely nothing works.  

Another oddity is that my Epson printer has been wirelessly connected to my Macbook via “Shared” exactly the way My Book Live used to be and I have had no problems with it. The Epson printer still works and remains connected via Shared.  That’s exactly where My Book Live used to be connected but no more.  

I also installed WD MyCloud app and tried connecting from my Macbook to My Book Live. Although the app sees My Book Live and lists it as a “Connected WD Device”, below that image it says “Devices Connected to to Your Network” with NOTHING listed. If I choose the “connect manually” option I enter my login info (same as I had always to connect to it via my smartphone), it tries, but I get a “can’t connect” error message.  If I click on the My Book Live icon directly to connect, I ultimately get the same  “can’t connect” error message.

Sorry for the long post and please excuse my “ludditeness”.  I wish I could offer help to others who’ve lost their connection, but alas I am just another sleep deprived lost sheep.  I have tried numerous other options to connect as well, but I won’t list them all here bc this message is too long already.  I should add that my WD My Book Live was not pre-formatted for Mac.  When I bought it, I was told by Office Depot, that as the box said, it works with PC or Mac.  I  don’t recall ever formatting it for my Macbook either.  It seemed to work fairly “plug in play” easily out of the box.  

I appreciate any suggestions and would even be happy to reconnect it directly to my Mac with ethernet if someone knew how to access the files that way.  Like everyone else, I cannot afford to lose 2TB of work.

Thanks in advance for any advice.  I have lost several night’s sleep and missed work a couple days trying to fix this. I have delayed the inevitable call to WD as long as I can, but I fear it may be necessary.