Macbook Pro can't find my My Book Live 2TB

Hello everybody!

I am frustrated :frowning: I just bought the WD My Book Live 2TB today, especially because of the support for Time Machine on my macbook pro.

I came home and plugged it in, first power, than into the wireless router - just as mentioned on the quick start guide. Green light and everything seemd to be ok. Then I started the software as mentioned on my macbook. There the problems started: the software cannot find the harddisk. It says, I should check connections and cables; which I did but everything is ok!

My setup at home is as follows:

---- Internet cable ----> modem —> Wireless Router (D-Link DIR300) —> Wireless to my macbook and occasionally connected via ethernet cable to an old desktop PC with Win7 and also occasionally connected via WLan to my old notebook with win 7.

Here are my problems:

When the hard disk is connected to the wireless it doesn’t automatically show up in Finder nor in Time Machine, as it actually should be compared to the manual. i cannot choose the Mybooklive for Time Machine under Mac OS X.

So I started to search in the internet for a solution…

What I found out so far is, that on my win7 pc I DO FIND the my book live under network drives and I can access everything. Just automatically via WLan… so the disk should work :slight_smile: What does NOT work however is to search for it via the CD resp. the software which is mentioned in the quick start guide.

What worked so far:

I managed to connect the harddrive via “Go to -> connect to server” and entered “afp://192.168.1.111” - after that I was able to connect the hard disk and mount the “Public” drive. I already gave the harddisk a fix IP (see above) and I can ping it and I can open to webbased config stuff…

But I want the hard disk to work automatically. I don’t want to mount it everytime, when WD actually promises that it works automatically :slight_smile:

Can you help me with this?!

Thanks for your help in advance!!!

Kind regards from Austria,

griesTraum

By the way: I found a thread, which is similary to my situation: http://community.wdc.com/t5/My-Book-Live/Does-not-recognise-MyBookLive-on-a-Mac/td-p/130848 but there hasn’t been a solution so far… :frowning:

my system by the way is a macbook pro 13" with snow leopard, bought october 2010, D-Link DIR 300 Router

Ok everybody, after a long search I found a solution!

The My Book Live drive is now recognised automatically in finder and visible under bonjour in safari.

Time Machine now recognizes the drive automatically.

I’m not sure, what really helped, but here’s what I did:

  • In my router settings, I disable “multicast data streams”

  • I checked the network settings of the harddrive via safari:

Be sure, that you specifiy  a static IP adress, fitting to your network. For example: my network starts at 192.168.0.100. So I definied 192.168.0.111 to be the static IP of the my book live. Then be sure to specify the netmask with 255.255.255.0 and the gateway with the IP adress of the wireless router (which was 192.168.0.1 in my case). Then define a DNS server, which is the same adress as the routers gateway (192.168.0.1).

Thats it: start again, and now the drive should appear in finder and safari at bonjour.

Hope I could help y’all!

Regards,

griesTraum

Helpful links:

http://community.wdc.com/t5/My-Book-Live/My-Book-live-kind-of-works-not-found-by-Mac-OS/td-p/202888

Glad you got it to work. Does it not work if you leave the Static IP set and enable multicast data streams?

So, by setting the ip as static, along with the subnet mask and the DNS server, you were able to get the drive to mount everytime? 

Glad you got it to work. Does it not work if you leave the Static IP set and enable multicast data streams?

 I just tried it - If I enable multicast and wireless enhanced mode the hard disk is not found automatically, just via the static IP I can access the webbased control stuff.

Is multicast importtant? I read, that it’s just needed for webservers? And what about wireless enhanced mode?

About the speed now …

I am not sure if disabling these options is a good idea, because my macbook shows a transferrate (writing to the disk) of about 3 - 3,5 MByte / s, whereas connecting it directly to the ethernet port by cable shows a rate of 20 - 25 MB / s so a lot faster … for example: copying 2 GB to the disk needs around 10 Minutes, copying the same amount via the ethernet cable takes only about a minute!

For the first backup the ethernet cable is now plugged in but is my router a real bottleneck here??

Do I need a new router now as well ??? Should I’ve bought a USB or Firewire disk instead :slight_smile: ???

No idea? Anyone?

Multicast is important for bonjour because bonjour uses mDNS (multicast DNS) to find resources.

Before answering whether your router is the bottleneck, I should point out the the speed you’re describing indicates that you’re using Wireless G, which caps out around 4 or 5 MB/s under ideal conditions.  Wireless N in the 5GHz range will top out at about 9MB/s.  As you’ve discovered, Gigabit ethernet is much faster, and has a theoretical limit of 100MB/s, although the drive can only do around 20 to 30MB/s under ideal conditions.

Some switches only support Fast Ethernet on their wired ports, which has a theoretical top speed of about 10MB/s.

What happens if you connect through the router via wires only?  Turn off the wireless.

From what I understand, multicast support shouldn’t hide the drive from their Mac.  I would see if there is any firmware update for the router.  If you want to do a static IP then I would assign that at the drive rather than the router (via DHCP). Make sure the MBL is on the current Lion-compatible firmware too.

I feel these solutions are far too technical for the average joe. I also think you should have a LiveChat to help out. I just got a printer problem fixed promptly and efficiently with LexMark LiveChat.

I can’t get access to my WD Live from my Mac. The green light is not lit on the front of the machine. An ethernet cable connects the WD to my router. Amber light on the back is solid, green light blinks. My PC sees the WD and can back up to it, but the Mac can’t see it.

What’s the problem?